summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 15:30:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 15:31:49 +0200
commit542ec773a991348223730e7859e78f45c6b2c895 (patch)
treed325235a359d994297bf9b5619f64ef205042c10 /media-libs/libde265/libde265-9999.ebuild
parentdev-lang/python: amd64 stable wrt bug #647862 (diff)
downloadgentoo-542ec773a991348223730e7859e78f45c6b2c895.tar.gz
gentoo-542ec773a991348223730e7859e78f45c6b2c895.tar.bz2
gentoo-542ec773a991348223730e7859e78f45c6b2c895.zip
media-libs/libde265: Add missing MULTILIB_USEDEP, fix USE=qt5
Qt5 is not multilib enabled, so disable if !multilib_is_native_abi Bug: https://bugs.gentoo.org/656772 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-libs/libde265/libde265-9999.ebuild')
-rw-r--r--media-libs/libde265/libde265-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
index 271e443495b1..91cbdf94843c 100644
--- a/media-libs/libde265/libde265-9999.ebuild
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit autotools multilib-minimal
@@ -21,11 +21,11 @@ HOMEPAGE="https://github.com/strukturag/libde265"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="debug qt5 static-libs cpu_flags_x86_sse"
+IUSE="cpu_flags_x86_sse debug qt5 static-libs"
DEPEND="
- media-libs/libsdl
- virtual/ffmpeg
+ media-libs/libsdl[${MULTILIB_USEDEP}]
+ virtual/ffmpeg[${MULTILIB_USEDEP}]
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -50,10 +50,18 @@ multilib_src_configure() {
$(use_enable debug log-info)
$(use_enable debug log-debug)
$(use_enable debug log-trace)
- $(use_enable qt5 dec265)
- $(use_enable qt5 sherlock265)
--enable-log-error
)
+
+ if ! multilib_is_native_abi; then
+ myeconfargs+=( --disable-dec265 --disable-sherlock265 )
+ else
+ myeconfargs+=(
+ $(use_enable qt5 dec265)
+ $(use_enable qt5 sherlock265)
+ )
+ fi
+
econf "${myeconfargs[@]}"
}