summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libfame/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libfame/files')
-rw-r--r--media-libs/libfame/files/libfame-0.9.1-gcc43.patch33
-rw-r--r--media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch20
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/libfame/files/libfame-0.9.1-gcc43.patch b/media-libs/libfame/files/libfame-0.9.1-gcc43.patch
new file mode 100644
index 000000000000..71fdbf59c522
--- /dev/null
+++ b/media-libs/libfame/files/libfame-0.9.1-gcc43.patch
@@ -0,0 +1,33 @@
+diff -rupN libfame-0.9.1b/src/fame_motion_pmvfast.c libfame-0.9.1/src/fame_motion_pmvfast.c
+--- libfame-0.9.1b/src/fame_motion_pmvfast.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_motion_pmvfast.c 2009-02-03 01:31:33.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "fame.h"
+ #include "fame_malloc.h"
+ #include "fame_motion.h"
+diff -rupN libfame-0.9.1b/src/fame_rate_1param.c libfame-0.9.1/src/fame_rate_1param.c
+--- libfame-0.9.1b/src/fame_rate_1param.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_rate_1param.c 2009-02-03 01:31:15.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #include "fame.h"
+ #include "fame_rate_1param.h"
+diff -rupN libfame-0.9.1b/src/fame_rate_simple.c libfame-0.9.1/src/fame_rate_simple.c
+--- libfame-0.9.1b/src/fame_rate_simple.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_rate_simple.c 2009-02-03 01:30:57.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #include "fame.h"
+ #include "fame_rate_simple.h"
diff --git a/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch b/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch
new file mode 100644
index 000000000000..ff4e7327ce2f
--- /dev/null
+++ b/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch
@@ -0,0 +1,20 @@
+Index: libfame-0.9.1/configure.in
+===================================================================
+--- libfame-0.9.1.orig/configure.in
++++ libfame-0.9.1/configure.in
+@@ -101,12 +101,9 @@ if test x$ac_cv_prog_gcc = xyes; then
+ CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
+
+ dnl -fstrict-aliasing doesn't seem to be supported by gcc < 2.95
+- gcc_major_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+- gcc_minor_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+- gcc_micro_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ gcc_major_version=`${CC} -dumpversion | cut -f1 -d.`
++ gcc_minor_version=`${CC} -dumpversion | cut -f2 -d.`
++ gcc_micro_version=`${CC} -dumpversion | cut -f3 -d.`
+
+ dnl ok, I must admit I don't know how to do or/and ;)
+ if test $gcc_major_version -eq 2; then