summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-21 00:29:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-21 00:29:49 +0200
commit5d7d4793015745ee7ae403c7dc7466fa748f131e (patch)
treecb6dff39c9a6868132501ec44b47c1e54c17adb3 /media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
parentsci-visualization/labplot: Set VIRTUALX_REQUIRED="test" (diff)
downloadgentoo-5d7d4793015745ee7ae403c7dc7466fa748f131e.tar.gz
gentoo-5d7d4793015745ee7ae403c7dc7466fa748f131e.tar.bz2
gentoo-5d7d4793015745ee7ae403c7dc7466fa748f131e.zip
media-libs/liblastfm: Force c++14 to fix build with GCC-11
Closes: https://bugs.gentoo.org/787128 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild')
-rw-r--r--media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild b/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
index e7a0b783f0a5..e8a9dfa10853 100644
--- a/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
+++ b/media-libs/liblastfm/liblastfm-1.1.0_pre20190625.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
COMMIT=f867df52757c569d97d9755c911ac9dec146f365
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Collection of libraries to integrate Last.fm services"
HOMEPAGE="https://github.com/lastfm/liblastfm"
@@ -36,6 +36,11 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${P}-missing-dep.patch" )
+src_prepare() {
+ append-cxxflags -std=c++14 # bug 787128
+ cmake_src_prepare
+}
+
src_configure() {
# demos not working
local mycmakeargs=(