summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmatroska/libmatroska-1.3.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmatroska/libmatroska-1.3.0.ebuild')
-rw-r--r--media-libs/libmatroska/libmatroska-1.3.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libmatroska/libmatroska-1.3.0.ebuild b/media-libs/libmatroska/libmatroska-1.3.0.ebuild
new file mode 100644
index 000000000000..a382c7adc54a
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/libebml-1.2.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/make/linux"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.0-respectflags.patch"
+}
+
+src_compile() {
+ local targets="sharedlib"
+ use static-libs && targets+=" staticlib"
+
+ #fixes locale for gcc3.4.0 to close bug 52385
+ append-flags $(test-flags -finput-charset=ISO8859-15)
+
+ emake PREFIX="${EPREFIX}"/usr \
+ LIBEBML_INCLUDE_DIR="${EPREFIX}"/usr/include/ebml \
+ LIBEBML_LIB_DIR="${EPREFIX}"/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ ${targets}
+}
+
+src_install() {
+ local targets="install_sharedlib install_headers"
+ use static-libs && targets+=" install_staticlib"
+
+ emake prefix="${ED}/usr" libdir="${ED}/usr/$(get_libdir)" ${targets}
+ dodoc "${WORKDIR}/${P}/ChangeLog"
+}