summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-11-17 22:09:15 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-11-17 22:18:34 +0100
commit9d1550f3fbd43acca0048710c4030d475e286997 (patch)
tree3a75f4b455ee8117efbe9b1a1afbd4336ab96634 /media-libs/libopenraw
parentprofiles: Update audacious use.mask description, unmask on amd64/x86 (diff)
downloadgentoo-9d1550f3fbd43acca0048710c4030d475e286997.tar.gz
gentoo-9d1550f3fbd43acca0048710c4030d475e286997.tar.bz2
gentoo-9d1550f3fbd43acca0048710c4030d475e286997.zip
Revert "media-libs/libopenraw: cleanup old revision"
This reverts commit 1be286da0397b2543d57ebc7ef0d7171fb2686e9. Still used by gegl:0.2 and gegl:0.3. Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'media-libs/libopenraw')
-rw-r--r--media-libs/libopenraw/Manifest1
-rw-r--r--media-libs/libopenraw/libopenraw-0.0.9.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libopenraw/Manifest b/media-libs/libopenraw/Manifest
index dcb939936d76..74487bd98778 100644
--- a/media-libs/libopenraw/Manifest
+++ b/media-libs/libopenraw/Manifest
@@ -1 +1,2 @@
+DIST libopenraw-0.0.9.tar.bz2 478687 BLAKE2B d51410aa2a4ce297c660f80f99c912374faf05c0920be0c9dff78c5979c553cd74aafed0591bd62d479825cb0fd7064b47b86747ecddc75cc177b54184eb42b1 SHA512 88d475d27719212686a0a5a08da04d6879fd456ec8f7531f401217df97f4f3d4c52dc8c4fb1c6ca88c12d6a67ecd516b151c5e9dceba9cbfcd13150fe81d6db5
DIST libopenraw-0.1.2.tar.bz2 563981 BLAKE2B 60332274c72602e5b3eea3e41dfee8c62303a2f09028df4a637cea6f07391d912f354752cb6f354e06dd9e223dfabe5dbed1d50e0f325d85be42fb5012ecede6 SHA512 edd7e5a71feecbce1d5a20622bd3c7111acd2d4792038fd19920367ebb55d2cc7614627b9739512bbe34d6b5ae2eb65a4da9cee70c400b5cb846bf5fff08efc8
diff --git a/media-libs/libopenraw/libopenraw-0.0.9.ebuild b/media-libs/libopenraw/libopenraw-0.0.9.ebuild
new file mode 100644
index 000000000000..5c269828d8fa
--- /dev/null
+++ b/media-libs/libopenraw/libopenraw-0.0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A decoding library for RAW image formats"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/"
+SRC_URI="https://${PN}.freedesktop.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="gtk static-libs test"
+
+RDEPEND="virtual/jpeg:0
+ dev-libs/libxml2
+ gtk? (
+ >=dev-libs/glib-2
+ >=x11-libs/gdk-pixbuf-2.24.0:2
+ )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.35
+ virtual/pkgconfig
+ test? ( net-misc/curl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ has_version '>=media-libs/jpeg-9a:0' && epatch "${FILESDIR}"/${P}-jpeg-9a.patch
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ $(use_enable static-libs static) \
+ $(use_enable gtk gnome)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}