summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-17 13:02:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-30 21:04:22 +0200
commit4d3ff2f1924ae1df716b910b256352c7c0c5bf90 (patch)
tree279ac918ddfcd811e7f35d70327c5e0b1de9696c /media-libs/libopenshot
parentmedia-libs/libopenshot-audio: Drop 0.1.9_pre20190502 (diff)
downloadgentoo-4d3ff2f1924ae1df716b910b256352c7c0c5bf90.tar.gz
gentoo-4d3ff2f1924ae1df716b910b256352c7c0c5bf90.tar.bz2
gentoo-4d3ff2f1924ae1df716b910b256352c7c0c5bf90.zip
media-libs/libopenshot: Drop 0.2.4_pre20190609
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/files/libopenshot-0.2.2-imagemagick7.patch78
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild101
3 files changed, 0 insertions, 180 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index 3d66306ec185..fd37645a4e66 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1,2 +1 @@
-DIST libopenshot-0.2.4_pre20190609.tar.gz 10268173 BLAKE2B 01e07c0a7c051b5804f24fab1bfb920862a165ef14d3fdd020430b9e3a47858842c8cab3408ba0d161cb15cc6e90531a3b5df9ad327a01f414ff2e7e392fc243 SHA512 bf8c06aba6a899cb1ca6fbe9ac89fc859083b03175338c04af8dce68698f4ac78eac0b5b594e2b02390cd5e64576445b1c95324b254a267506353bed97ca16d1
DIST libopenshot-0.2.5.tar.gz 10295768 BLAKE2B 19205c4f02d8b863b48e920164302853c7a505893783161e6a146e7a9728cefa19d4e48bc82b862e920967f110988ac28f5f495912efabbbacc98f55ebb51856 SHA512 b7cdf72897e6edaa8cc00e17dbe30f5b22a6b5d69aab64ddafb184458b41ef0332db1f3e2c6f039492bf7adb521d9758834d0bf6c24e6421a55970d8cf8caba7
diff --git a/media-libs/libopenshot/files/libopenshot-0.2.2-imagemagick7.patch b/media-libs/libopenshot/files/libopenshot-0.2.2-imagemagick7.patch
deleted file mode 100644
index bc5f738d7f63..000000000000
--- a/media-libs/libopenshot/files/libopenshot-0.2.2-imagemagick7.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -Nru a/include/TextReader.h b/include/TextReader.h
---- a/include/TextReader.h 2018-09-22 21:47:46.000000000 +0200
-+++ b/include/TextReader.h 2018-09-23 16:17:21.212888285 +0200
-@@ -91,7 +91,7 @@
- string text_color;
- string background_color;
- std::shared_ptr<Magick::Image> image;
-- list<Magick::Drawable> lines;
-+ vector<Magick::Drawable> lines;
- bool is_open;
- GravityType gravity;
-
-diff -Nru a/src/Frame.cpp b/src/Frame.cpp
---- a/src/Frame.cpp 2018-09-22 21:47:46.000000000 +0200
-+++ b/src/Frame.cpp 2018-09-23 16:21:44.921563711 +0200
-@@ -29,6 +29,9 @@
-
- using namespace std;
- using namespace openshot;
-+#ifdef USE_IMAGEMAGICK
-+using namespace Magick;
-+#endif
-
- // Constructor - blank frame (300x200 blank image, 48kHz audio silence)
- Frame::Frame() : number(1), pixel_ratio(1,1), channels(2), width(1), height(1), color("#000000"),
-@@ -904,7 +907,7 @@
- // Give image a transparent background color
- magick_image->backgroundColor(Magick::Color("none"));
- magick_image->virtualPixelMethod(Magick::TransparentVirtualPixelMethod);
-- magick_image->matte(true);
-+ magick_image->alpha(true);
-
- return magick_image;
- }
-@@ -926,13 +929,14 @@
- // Iterate through the pixel packets, and load our own buffer
- // Each color needs to be scaled to 8 bit (using the ImageMagick built-in ScaleQuantumToChar function)
- int numcopied = 0;
-- Magick::PixelPacket *pixels = new_image->getPixels(0,0, new_image->columns(), new_image->rows());
-+ const Quantum *pixels = new_image->getConstPixels(0,0, new_image->columns(), new_image->rows());
- for (int n = 0, i = 0; n < new_image->columns() * new_image->rows(); n += 1, i += 4) {
-- buffer[i+0] = MagickCore::ScaleQuantumToChar((Magick::Quantum) pixels[n].red);
-- buffer[i+1] = MagickCore::ScaleQuantumToChar((Magick::Quantum) pixels[n].green);
-- buffer[i+2] = MagickCore::ScaleQuantumToChar((Magick::Quantum) pixels[n].blue);
-- buffer[i+3] = 255 - MagickCore::ScaleQuantumToChar((Magick::Quantum) pixels[n].opacity);
-+ buffer[i+0] = MagickCore::ScaleQuantumToChar(MagickCore::GetPixelRed(new_image->image(), pixels));
-+ buffer[i+1] = MagickCore::ScaleQuantumToChar(MagickCore::GetPixelGreen(new_image->image(), pixels));
-+ buffer[i+2] = MagickCore::ScaleQuantumToChar(MagickCore::GetPixelBlue(new_image->image(), pixels));
-+ buffer[i+3] = MagickCore::ScaleQuantumToChar(MagickCore::GetPixelAlpha(new_image->image(), pixels));
- numcopied+=4;
-+ pixels += MagickCore::GetPixelChannels(new_image->image());
- }
-
- // Create QImage of frame data
-diff -Nru a/src/ImageReader.cpp b/src/ImageReader.cpp
---- a/src/ImageReader.cpp 2018-09-22 21:47:46.000000000 +0200
-+++ b/src/ImageReader.cpp 2018-09-23 16:22:32.330865516 +0200
-@@ -59,7 +59,7 @@
-
- // Give image a transparent background color
- image->backgroundColor(Magick::Color("none"));
-- image->matte(true);
-+ image->alpha(true);
- }
- catch (Magick::Exception e) {
- // raise exception
-diff -Nru a/src/ImageWriter.cpp b/src/ImageWriter.cpp
---- a/src/ImageWriter.cpp 2018-09-22 21:47:46.000000000 +0200
-+++ b/src/ImageWriter.cpp 2018-09-23 16:22:58.380031419 +0200
-@@ -97,7 +97,7 @@
- std::shared_ptr<Magick::Image> frame_image = frame->GetMagickImage();
- frame_image->magick( info.vcodec );
- frame_image->backgroundColor(Magick::Color("none"));
-- frame_image->matte(true);
-+ frame_image->alpha(true);
- frame_image->quality(image_quality);
- frame_image->animationDelay(info.video_timebase.ToFloat() * 100);
- frame_image->animationIterations(number_of_loops);
diff --git a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
deleted file mode 100644
index eea5ca7a14f4..000000000000
--- a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit cmake python-single-r1 toolchain-funcs
-
-COMMIT="0d4ea7fe71e88bcee4a7fd1404bd52c8e2169997"
-
-DESCRIPTION="Video editing library used by OpenShot"
-HOMEPAGE="https://www.openshot.org/"
-SRC_URI="https://github.com/OpenShot/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/17"
-KEYWORDS="amd64 x86"
-IUSE="doc examples +imagemagick +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- net-libs/cppzmq
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5[widgets]
- >=media-libs/libopenshot-audio-0.1.9_pre20190502:0=
- imagemagick? ( >=media-gfx/imagemagick-7:0=[cxx] )
- media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora]
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? ( app-doc/doxygen )
- python? ( dev-lang/swig )
- test? ( dev-libs/unittest++ )
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-# From Mageia
-# https://github.com/OpenShot/libopenshot/issues/60
-PATCHES=( ${FILESDIR}/${PN}-0.2.2-imagemagick7.patch )
-
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
-pkg_pretend() {
- check_compiler
-}
-
-pkg_setup() {
- check_compiler
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # https://github.com/OpenShot/libopenshot/issues/17
- use test || cmake_comment_add_subdirectory tests
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_RUBY=OFF # TODO: add ruby support
- -DENABLE_PYTHON=$(usex python)
- $(cmake_use_find_package imagemagick ImageMagick)
- )
- use python && mycmakeargs+=(
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doc
-}
-
-src_test() {
- cmake_build os_test
-}
-
-src_install() {
- local DOCS=( AUTHORS README.md doc/HW-ACCEL.md )
- use examples && DOCS+=( src/examples/ )
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
-
- cmake_src_install
- use python && python_optimize
-}