summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2021-09-04 22:15:09 +0300
committerStefan Strogin <steils@gentoo.org>2021-09-04 19:19:45 +0000
commit8224634b6264d6e59d22a1c90ffbc73673fb9776 (patch)
tree415d84d0829c49fe7654dbfc40cabdfa5691c6b4 /media-libs/libopenshot
parentmedia-libs/libopenshot-audio: upgrade to 0.2.1 (diff)
downloadgentoo-8224634b6264d6e59d22a1c90ffbc73673fb9776.tar.gz
gentoo-8224634b6264d6e59d22a1c90ffbc73673fb9776.tar.bz2
gentoo-8224634b6264d6e59d22a1c90ffbc73673fb9776.zip
media-libs/libopenshot: upgrade to 0.2.6
Bug: https://bugs.gentoo.org/810484 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.6.ebuild100
-rw-r--r--media-libs/libopenshot/metadata.xml5
3 files changed, 106 insertions, 0 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index fd37645a4e66..d7b81431b763 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1 +1,2 @@
DIST libopenshot-0.2.5.tar.gz 10295768 BLAKE2B 19205c4f02d8b863b48e920164302853c7a505893783161e6a146e7a9728cefa19d4e48bc82b862e920967f110988ac28f5f495912efabbbacc98f55ebb51856 SHA512 b7cdf72897e6edaa8cc00e17dbe30f5b22a6b5d69aab64ddafb184458b41ef0332db1f3e2c6f039492bf7adb521d9758834d0bf6c24e6421a55970d8cf8caba7
+DIST libopenshot-0.2.6.tar.gz 22472140 BLAKE2B 7ad35cfb927e637c4ded38de751f3f484ab6f051a2eea15153dcf4a66a378023883e76ffde361725a2285018741765fece01a60443421d95a8a772065d9de199 SHA512 13706733280e8c70638a02ad220e6a84f3d26a5a35f5f8f1b820408236aeda8bd8683e19a85a0d466007a1d711ca31bb436f8d4ca4fb6ffbfe169b2976dea525
diff --git a/media-libs/libopenshot/libopenshot-0.2.6.ebuild b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
new file mode 100644
index 000000000000..af6f8eedbf89
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit cmake python-single-r1 toolchain-funcs
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/20"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +imagemagick +opencv +python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/jsoncpp:0=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ >=media-libs/libopenshot-audio-0.2.1:0=
+ media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora,vorbis]
+ net-libs/cppzmq
+ net-libs/zeromq
+ imagemagick? ( >=media-gfx/imagemagick-7:0=[cxx] )
+ opencv? ( >=media-libs/opencv-4.5.2:=[contrib,contribdnn] )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+ test? (
+ dev-cpp/catch:0
+ dev-libs/unittest++
+ )"
+
+check_compiler() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_pretend() {
+ check_compiler
+}
+
+pkg_setup() {
+ check_compiler
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_BUNDLED_JSONCPP=ON
+ -DENABLE_MAGICK=$(usex imagemagick)
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_TESTS=$(usex test)
+ -DUSE_SYSTEM_JSONCPP=ON
+ $(cmake_use_find_package imagemagick ImageMagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}
+
+src_test() {
+ cmake_build test
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.md doc/HW-ACCEL.md )
+ use examples && DOCS+=( examples/ )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ cmake_src_install
+ use python && python_optimize
+}
diff --git a/media-libs/libopenshot/metadata.xml b/media-libs/libopenshot/metadata.xml
index 5ca3390a69fd..b1502b801e4f 100644
--- a/media-libs/libopenshot/metadata.xml
+++ b/media-libs/libopenshot/metadata.xml
@@ -13,4 +13,9 @@
<remote-id type="github">OpenShot/libopenshot</remote-id>
<bugs-to>https://github.com/OpenShot/libopenshot/issues</bugs-to>
</upstream>
+ <use>
+ <flag name="opencv">
+ Enable <pkg>media-libs/opencv</pkg> support
+ </flag>
+ </use>
</pkgmetadata>