summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-22 09:24:37 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-22 23:30:03 +0800
commit9046ae2da5fac8aef16e43a4e75b15037923c81f (patch)
tree8d2a51f676bd1dacc29164d1843cd1597ea6f619 /media-libs/libopenshot
parentapp-admin/lastpass-binary-component: new package #571280 (diff)
downloadgentoo-9046ae2da5fac8aef16e43a4e75b15037923c81f.tar.gz
gentoo-9046ae2da5fac8aef16e43a4e75b15037923c81f.tar.bz2
gentoo-9046ae2da5fac8aef16e43a4e75b15037923c81f.zip
media-libs/libopenshot: make sure the compiler supports OpenMP
Gentoo-Bug: 580710 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1321 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/libopenshot-0.1.1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/media-libs/libopenshot/libopenshot-0.1.1.ebuild b/media-libs/libopenshot/libopenshot-0.1.1.ebuild
index 8253c49c0b0b..5bc4acc70516 100644
--- a/media-libs/libopenshot/libopenshot-0.1.1.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.1.1.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python3_{4,5} )
-inherit cmake-utils python-single-r1 versionator
+inherit cmake-utils python-single-r1 toolchain-funcs versionator
DESCRIPTION="Video editing library used by OpenShot"
HOMEPAGE="http://www.openshotvideo.com/"
@@ -40,6 +40,15 @@ PATCHES=( "${FILESDIR}/${PN}-0.1.0-fix-tests-exit-code.patch" )
S="${WORKDIR}"
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}