summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.xyz>2020-04-22 09:28:28 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-23 10:06:47 -0700
commitbd3a073903dbc077d399f00d54fba0859a1facbb (patch)
tree785af77ced0dcc9104ec6a0e3a89c46deb269ae4 /media-libs/libplacebo/libplacebo-9999.ebuild
parentprofiles/arch/sparc/64ul/package.use.mask: drop sparc64-specific unmask (diff)
downloadgentoo-bd3a073903dbc077d399f00d54fba0859a1facbb.tar.gz
gentoo-bd3a073903dbc077d399f00d54fba0859a1facbb.tar.bz2
gentoo-bd3a073903dbc077d399f00d54fba0859a1facbb.zip
media-libs/libplacebo: update to v2.43.0
This includes a new USE flag, for the OpenGL support added in this version of libplacebo. We bump up the test timeout because the OpenGL tests can take a while to execute, especially on machines where they're running via llvmpipe or swrast. Also synchronize the live ebuild. Signed-off-by: Niklas Haas <git@haasn.xyz> Closes: https://github.com/gentoo/gentoo/pull/15465 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/libplacebo/libplacebo-9999.ebuild')
-rw-r--r--media-libs/libplacebo/libplacebo-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-libs/libplacebo/libplacebo-9999.ebuild b/media-libs/libplacebo/libplacebo-9999.ebuild
index 53dde3ad005e..1c2ef2ff86ae 100644
--- a/media-libs/libplacebo/libplacebo-9999.ebuild
+++ b/media-libs/libplacebo/libplacebo-9999.ebuild
@@ -7,7 +7,7 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://code.videolan.org/videolan/libplacebo.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
SRC_URI="https://code.videolan.org/videolan/libplacebo/-/archive/v${PV}/libplacebo-v${PV}.tar.gz"
S="${WORKDIR}/${PN}-v${PV}"
fi
@@ -20,11 +20,12 @@ HOMEPAGE="https://github.com/haasn/libplacebo"
LICENSE="LGPL-2.1+"
# Please add a sub-slot for releases depending on libplacebo.so version
SLOT="0"
-IUSE="glslang lcms +shaderc test +vulkan"
+IUSE="glslang lcms +opengl +shaderc test +vulkan"
REQUIRED_USE="vulkan? ( || ( glslang shaderc ) )"
RDEPEND="glslang? ( dev-util/glslang[${MULTILIB_USEDEP}] )
lcms? ( media-libs/lcms:2[${MULTILIB_USEDEP}] )
+ opengl? ( media-libs/libepoxy[${MULTILIB_USEDEP}] )
shaderc? ( >=media-libs/shaderc-2017.2[${MULTILIB_USEDEP}] )
vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
@@ -36,6 +37,7 @@ multilib_src_configure() {
local emesonargs=(
$(meson_feature glslang)
$(meson_feature lcms)
+ $(meson_feature opengl)
$(meson_feature shaderc)
$(meson_feature vulkan)
$(meson_use test tests)
@@ -48,7 +50,7 @@ multilib_src_compile() {
}
multilib_src_test() {
- meson_src_test
+ meson_src_test -t 10
}
multilib_src_install() {