summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-10-12 17:44:38 +0200
committerSam James <sam@gentoo.org>2022-10-13 20:40:39 +0100
commit611ed99278cdfcdc7978af1c651ff4f72947cc5d (patch)
tree96641e29aa64b6ca09d4dc9e0e99ca17a4bf6784 /media-libs/librtprocess
parentdev-java/browserlauncher2: Stabilize 1.3-r3 ppc64, #876919 (diff)
downloadgentoo-611ed99278cdfcdc7978af1c651ff4f72947cc5d.tar.gz
gentoo-611ed99278cdfcdc7978af1c651ff4f72947cc5d.tar.bz2
gentoo-611ed99278cdfcdc7978af1c651ff4f72947cc5d.zip
media-libs/librtprocess: add dependency to openmp
Closes: https://bugs.gentoo.org/876352 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27752 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/librtprocess')
-rw-r--r--media-libs/librtprocess/librtprocess-0.12.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/librtprocess/librtprocess-0.12.0-r1.ebuild b/media-libs/librtprocess/librtprocess-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..aec961e0c1e1
--- /dev/null
+++ b/media-libs/librtprocess/librtprocess-0.12.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Algorithms for RAW processing from RawTherapee"
+HOMEPAGE="https://github.com/CarVac/librtprocess/"
+SRC_URI="https://github.com/CarVac/librtprocess/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+BDEPEND="
+ openmp? (
+ || (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
+ )
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ )
+ cmake_src_configure
+}