summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-24 20:43:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-24 21:35:09 -0400
commit74e12610ae4c66545f127e400e0a08bd7bc5a0d0 (patch)
tree3a940fbe917d2bc1c058f2f7316ba125ba0e765d /media-libs/libsdl/files
parentmedia-libs/sdl2-image: drop vulnerable 2.0.5 (diff)
downloadgentoo-74e12610ae4c66545f127e400e0a08bd7bc5a0d0.tar.gz
gentoo-74e12610ae4c66545f127e400e0a08bd7bc5a0d0.tar.bz2
gentoo-74e12610ae4c66545f127e400e0a08bd7bc5a0d0.zip
media-libs/libsdl: drop vulnerable 1.2.15-r9
Bug: https://bugs.gentoo.org/692388 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs/libsdl/files')
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-SDL_EnableUNICODE.patch47
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch28
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-caca.patch26
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-const-xdata32.patch58
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-joystick.patch13
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-resizing.patch60
6 files changed, 0 insertions, 232 deletions
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-SDL_EnableUNICODE.patch b/media-libs/libsdl/files/libsdl-1.2.15-SDL_EnableUNICODE.patch
deleted file mode 100644
index bf68b2e44f44..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-SDL_EnableUNICODE.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-
-diff -r 22a7f096bb9d -r 0aade9c0203f src/video/x11/SDL_x11events.c
---- a/src/video/x11/SDL_x11events.c Sun Dec 01 00:00:17 2013 -0500
-+++ b/src/video/x11/SDL_x11events.c Thu Apr 17 22:36:14 2014 -0700
-@@ -395,6 +395,8 @@
- {
- int posted;
- XEvent xevent;
-+ int orig_event_type;
-+ KeyCode orig_keycode;
-
- SDL_memset(&xevent, '\0', sizeof (XEvent)); /* valgrind fix. --ryan. */
- XNextEvent(SDL_Display, &xevent);
-@@ -410,9 +412,29 @@
- #ifdef X_HAVE_UTF8_STRING
- /* If we are translating with IM, we need to pass all events
- to XFilterEvent, and discard those filtered events immediately. */
-+ orig_event_type = xevent.type;
-+ if (orig_event_type == KeyPress || orig_event_type == KeyRelease) {
-+ orig_keycode = xevent.xkey.keycode;
-+ } else {
-+ orig_keycode = 0;
-+ }
- if ( SDL_TranslateUNICODE
- && SDL_IM != NULL
- && XFilterEvent(&xevent, None) ) {
-+ if (orig_keycode) {
-+ SDL_keysym keysym;
-+ static XComposeStatus state;
-+ char keybuf[32];
-+
-+ keysym.scancode = xevent.xkey.keycode;
-+ keysym.sym = X11_TranslateKeycode(SDL_Display, xevent.xkey.keycode);
-+ keysym.mod = KMOD_NONE;
-+ keysym.unicode = 0;
-+ if (orig_event_type == KeyPress && XLookupString(&xevent.xkey, keybuf, sizeof(keybuf), NULL, &state))
-+ keysym.unicode = (Uint8)keybuf[0];
-+
-+ SDL_PrivateKeyboard(orig_event_type == KeyPress ? SDL_PRESSED : SDL_RELEASED, &keysym);
-+ }
- return 0;
- }
- #endif
-
-
-
-
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch b/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch
deleted file mode 100644
index 0f3542529ba6..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-
-# HG changeset patch
-# User Sam Lantinga <slouken@libsdl.org>
-# Date 1329357968 18000
-# Node ID 62ff1c0a103f685774450be2e5338824a22078bd
-# Parent 8e98c714bb2ab96de4100a335dacf042963d5068
-FreeBSD compile fix
-
-Robert Millan
-
-src/joystick/bsd/SDL_sysjoystick.c makes the invalid assumption that
-__FreeBSD_kernel__ implies presence of "ucr_data" struct member. This
-breaks recent versions of FreeBSD 10-CURRENT, FreeBSD 9-STABLE and
-Debian GNU/kFreeBSD "wheezy/sid".
-
-diff -r 8e98c714bb2a -r 62ff1c0a103f src/joystick/bsd/SDL_sysjoystick.c
---- a/src/joystick/bsd/SDL_sysjoystick.c Sat Feb 04 18:12:20 2012 -0500
-+++ b/src/joystick/bsd/SDL_sysjoystick.c Wed Feb 15 21:06:08 2012 -0500
-@@ -148,7 +148,7 @@
- static int report_alloc(struct report *, struct report_desc *, int);
- static void report_free(struct report *);
-
--#if defined(USBHID_UCR_DATA) || defined(__FreeBSD_kernel__)
-+#if defined(USBHID_UCR_DATA)
- #define REP_BUF_DATA(rep) ((rep)->buf->ucr_data)
- #elif (defined(__FREEBSD__) && (__FreeBSD_kernel_version > 800063))
- #define REP_BUF_DATA(rep) ((rep)->buf->ugd_data)
-
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-caca.patch b/media-libs/libsdl/files/libsdl-1.2.15-caca.patch
deleted file mode 100644
index faf5ae132a96..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-caca.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- SDL-1.2.15/configure.in
-+++ SDL-1.2.15/configure.in
-@@ -1507,11 +1507,10 @@
- , enable_video_caca=no)
- if test x$enable_video = xyes -a x$enable_video_caca = xyes; then
- video_caca=no
-- AC_PATH_PROG(CACACONFIG, caca-config, no)
-- if test x$CACACONFIG != xno; then
-+ PKG_PROG_PKG_CONFIG([0.20])
-+ PKG_CHECK_MODULES(CACA, caca, has_caca_pc=yes, has_caca_pc=no])
-+ if test x$has_caca_pc == xyes; then
- AC_MSG_CHECKING(for libcaca support)
-- CACA_CFLAGS=`$CACACONFIG --cflags`
-- CACA_LDFLAGS=`$CACACONFIG --libs`
- save_CFLAGS="$CFLAGS"
- AC_TRY_COMPILE([
- #include <caca.h>
-@@ -1524,7 +1523,7 @@
- if test x$video_caca = xyes; then
- AC_DEFINE(SDL_VIDEO_DRIVER_CACA)
- EXTRA_CFLAGS="$EXTRA_CFLAGS $CACA_CFLAGS"
-- EXTRA_LDFLAGS="$EXTRA_LDFLAGS $CACA_LDFLAGS"
-+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS $CACA_LIBS"
- SOURCES="$SOURCES $srcdir/src/video/caca/*.c"
- fi
- fi
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-const-xdata32.patch b/media-libs/libsdl/files/libsdl-1.2.15-const-xdata32.patch
deleted file mode 100644
index ffe55348a6c6..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-const-xdata32.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-# HG changeset patch
-# User Azamat H. Hackimov <azamat.hackimov@gmail.com>
-# Date 1370184533 -21600
-# Branch SDL-1.2
-# Node ID 91ad7b43317a6387e115ecdf63a49137f47e42c8
-# Parent f7fd5c3951b9ed922fdf696f7182e71b58a13268
-Fix compilation with libX11 >= 1.5.99.902.
-
-These changes fixes bug #1769 for SDL 1.2
-(http://bugzilla.libsdl.org/show_bug.cgi?id=1769).
-
-diff -r f7fd5c3951b9 -r 91ad7b43317a configure.in
---- a/configure.in Wed Apr 17 00:56:53 2013 -0700
-+++ b/configure.in Sun Jun 02 20:48:53 2013 +0600
-@@ -1169,6 +1169,17 @@
- if test x$definitely_enable_video_x11_xrandr = xyes; then
- AC_DEFINE(SDL_VIDEO_DRIVER_X11_XRANDR)
- fi
-+ AC_MSG_CHECKING(for const parameter to _XData32)
-+ have_const_param_xdata32=no
-+ AC_TRY_COMPILE([
-+ #include <X11/Xlibint.h>
-+ extern int _XData32(Display *dpy,register _Xconst long *data,unsigned len);
-+ ],[
-+ ],[
-+ have_const_param_xdata32=yes
-+ AC_DEFINE(SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32)
-+ ])
-+ AC_MSG_RESULT($have_const_param_xdata32)
- fi
- fi
- }
-diff -r f7fd5c3951b9 -r 91ad7b43317a include/SDL_config.h.in
---- a/include/SDL_config.h.in Wed Apr 17 00:56:53 2013 -0700
-+++ b/include/SDL_config.h.in Sun Jun 02 20:48:53 2013 +0600
-@@ -283,6 +283,7 @@
- #undef SDL_VIDEO_DRIVER_WINDIB
- #undef SDL_VIDEO_DRIVER_WSCONS
- #undef SDL_VIDEO_DRIVER_X11
-+#undef SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32
- #undef SDL_VIDEO_DRIVER_X11_DGAMOUSE
- #undef SDL_VIDEO_DRIVER_X11_DYNAMIC
- #undef SDL_VIDEO_DRIVER_X11_DYNAMIC_XEXT
-diff -r f7fd5c3951b9 -r 91ad7b43317a src/video/x11/SDL_x11sym.h
---- a/src/video/x11/SDL_x11sym.h Wed Apr 17 00:56:53 2013 -0700
-+++ b/src/video/x11/SDL_x11sym.h Sun Jun 02 20:48:53 2013 +0600
-@@ -165,7 +165,11 @@
- */
- #ifdef LONG64
- SDL_X11_MODULE(IO_32BIT)
-+#if SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32
-+SDL_X11_SYM(int,_XData32,(Display *dpy,register _Xconst long *data,unsigned len),(dpy,data,len),return)
-+#else
- SDL_X11_SYM(int,_XData32,(Display *dpy,register long *data,unsigned len),(dpy,data,len),return)
-+#endif
- SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,len),)
- #endif
-
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-joystick.patch b/media-libs/libsdl/files/libsdl-1.2.15-joystick.patch
deleted file mode 100644
index 70e585e50132..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-joystick.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/joystick/linux/SDL_sysjoystick.c.org
-+++ src/joystick/linux/SDL_sysjoystick.c
-@@ -1106,6 +1106,10 @@ static __inline__ void EV_HandleEvents(S
- }
- break;
- case EV_ABS:
-+ if (code >= ABS_MISC) {
-+ break;
-+ }
-+
- switch (code) {
- case ABS_HAT0X:
- case ABS_HAT0Y:
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-resizing.patch b/media-libs/libsdl/files/libsdl-1.2.15-resizing.patch
deleted file mode 100644
index 5112137a5a17..000000000000
--- a/media-libs/libsdl/files/libsdl-1.2.15-resizing.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Description: Revert change that breaks window corner resizing
- http://bugzilla.libsdl.org/show_bug.cgi?id=1430
-Author: Andrew Caudwell <acaudwell@gmail.com>
-Last-Update: 2012-04-10
-Bug-Debian: http://bugs.debian.org/665779
-
---- a/src/video/x11/SDL_x11events.c
-+++ b/src/video/x11/SDL_x11events.c
-@@ -57,12 +57,6 @@
- static SDLKey MISC_keymap[256];
- SDLKey X11_TranslateKeycode(Display *display, KeyCode kc);
-
--/*
-- Pending resize target for ConfigureNotify (so outdated events don't
-- cause inappropriate resize events)
--*/
--int X11_PendingConfigureNotifyWidth = -1;
--int X11_PendingConfigureNotifyHeight = -1;
-
- #ifdef X_HAVE_UTF8_STRING
- Uint32 Utf8ToUcs4(const Uint8 *utf8)
-@@ -825,16 +819,6 @@
- #ifdef DEBUG_XEVENTS
- printf("ConfigureNotify! (resize: %dx%d)\n", xevent.xconfigure.width, xevent.xconfigure.height);
- #endif
-- if ((X11_PendingConfigureNotifyWidth != -1) &&
-- (X11_PendingConfigureNotifyHeight != -1)) {
-- if ((xevent.xconfigure.width != X11_PendingConfigureNotifyWidth) &&
-- (xevent.xconfigure.height != X11_PendingConfigureNotifyHeight)) {
-- /* Event is from before the resize, so ignore. */
-- break;
-- }
-- X11_PendingConfigureNotifyWidth = -1;
-- X11_PendingConfigureNotifyHeight = -1;
-- }
- if ( SDL_VideoSurface ) {
- if ((xevent.xconfigure.width != SDL_VideoSurface->w) ||
- (xevent.xconfigure.height != SDL_VideoSurface->h)) {
---- a/src/video/x11/SDL_x11events_c.h
-+++ b/src/video/x11/SDL_x11events_c.h
-@@ -27,8 +27,3 @@
- extern void X11_InitOSKeymap(_THIS);
- extern void X11_PumpEvents(_THIS);
- extern void X11_SetKeyboardState(Display *display, const char *key_vec);
--
--/* Variables to be exported */
--extern int X11_PendingConfigureNotifyWidth;
--extern int X11_PendingConfigureNotifyHeight;
--
---- a/src/video/x11/SDL_x11video.c
-+++ b/src/video/x11/SDL_x11video.c
-@@ -1182,8 +1182,6 @@
- current = NULL;
- goto done;
- }
-- X11_PendingConfigureNotifyWidth = width;
-- X11_PendingConfigureNotifyHeight = height;
- } else {
- if (X11_CreateWindow(this,current,width,height,bpp,flags) < 0) {
- current = NULL;