summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:40:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:57:46 +0100
commit98871a6eb946031d358895f30ef4d84519f9160c (patch)
tree4a8d489f541489831824d8f57ebc741b232eb7e2 /media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild
parentmedia-sound/sidplay: EAPI-7 bump (diff)
downloadgentoo-98871a6eb946031d358895f30ef4d84519f9160c.tar.gz
gentoo-98871a6eb946031d358895f30ef4d84519f9160c.tar.bz2
gentoo-98871a6eb946031d358895f30ef4d84519f9160c.zip
media-libs/libsidplayfp: 1.8.8 version bump
Closes: https://bugs.gentoo.org/656298 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild')
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild b/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild
new file mode 100644
index 000000000000..bf0faa527c68
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ # relies on undocumented "uint" type in libstdc++
+ # bug 649832
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}