summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libsvgtiny/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libsvgtiny/files')
-rw-r--r--media-libs/libsvgtiny/files/libsvgtiny-0.1.2-glibc2.20.patch18
-rw-r--r--media-libs/libsvgtiny/files/libsvgtiny-0.1.3-glibc2.20.patch18
-rw-r--r--media-libs/libsvgtiny/files/libsvgtiny-0.1.3-parallel-build.patch10
3 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/libsvgtiny/files/libsvgtiny-0.1.2-glibc2.20.patch b/media-libs/libsvgtiny/files/libsvgtiny-0.1.2-glibc2.20.patch
new file mode 100644
index 000000000000..3f5430248fb7
--- /dev/null
+++ b/media-libs/libsvgtiny/files/libsvgtiny-0.1.2-glibc2.20.patch
@@ -0,0 +1,18 @@
+--- libsvgtiny-0.1.2/Makefile
++++ libsvgtiny-0.1.2/Makefile
+@@ -15,14 +15,8 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs -pedantic
+-# BeOS/Haiku/AmigaOS standard library headers create warnings
+-ifneq ($(TARGET),beos)
+- ifneq ($(TARGET),amiga)
+- WARNFLAGS := $(WARNFLAGS) -Werror
+- endif
+-endif
+
+-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
++CFLAGS := -D_DEFAULT_SOURCE -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+ ifneq ($(GCCVER),2)
+ CFLAGS := $(CFLAGS) -std=c99
diff --git a/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-glibc2.20.patch b/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-glibc2.20.patch
new file mode 100644
index 000000000000..e04867fb35af
--- /dev/null
+++ b/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-glibc2.20.patch
@@ -0,0 +1,18 @@
+--- libsvgtiny-0.1.3/Makefile
++++ libsvgtiny-0.1.3/Makefile
+@@ -15,14 +15,8 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs -pedantic
+-# BeOS/Haiku/AmigaOS standard library headers create warnings
+-ifneq ($(BUILD),i586-pc-haiku)
+- ifneq ($(findstring amigaos,$(BUILD)),amigaos)
+- WARNFLAGS := $(WARNFLAGS) -Werror
+- endif
+-endif
+
+-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
++CFLAGS := -D_DEFAULT_SOURCE -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+ ifneq ($(GCCVER),2)
+ CFLAGS := $(CFLAGS) -std=c99
diff --git a/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-parallel-build.patch b/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-parallel-build.patch
new file mode 100644
index 000000000000..f647b155b3a9
--- /dev/null
+++ b/media-libs/libsvgtiny/files/libsvgtiny-0.1.3-parallel-build.patch
@@ -0,0 +1,10 @@
+--- libsvgtiny-0.1.3/src/Makefile
++++ libsvgtiny-0.1.3/src/Makefile
+@@ -5,6 +5,7 @@
+
+ $(BUILDDIR)/src_colors.c: src/colors.gperf
+ $(VQ)$(ECHO) " GPERF: $<"
++ mkdir -p $(@D)
+ $(Q)gperf --output-file=$@.tmp $<
+ # Hack for GCC 4.2 compatibility (gperf 3.0.4 solves this properly)
+ $(Q)$(SED) -e 's/#ifdef __GNUC_STDC_INLINE__/#if defined __GNUC_STDC_INLINE__ || defined __GNUC_GNU_INLINE__/' $@.tmp >$@