summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 01:53:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 02:01:17 +0200
commit92a952a998d41206b6af06fe2d9c3eb9ab2e3f4a (patch)
tree2b324b94acc43c1a7c93a21b0a3e71f7efcc071d /media-libs/libtheora/files
parentmedia-plugins/gst-plugins-wavpack: bump to 1.14.4, no code changes from 1.14.3 (diff)
downloadgentoo-92a952a998d41206b6af06fe2d9c3eb9ab2e3f4a.tar.gz
gentoo-92a952a998d41206b6af06fe2d9c3eb9ab2e3f4a.tar.bz2
gentoo-92a952a998d41206b6af06fe2d9c3eb9ab2e3f4a.zip
media-libs/libtheora: Fix undefined behaviour, EAPI-7 bump
Thanks-to: <moatu@opentrash.com> Bug: https://bugs.gentoo.org/620800 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'media-libs/libtheora/files')
-rw-r--r--media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch4
-rw-r--r--media-libs/libtheora/files/libtheora-1.1.1-fix-UB.patch47
-rw-r--r--media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch4
-rw-r--r--media-libs/libtheora/files/libtheora-1.1.1-underlinking.patch4
4 files changed, 53 insertions, 6 deletions
diff --git a/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch b/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch
index a47cc5771680..ffc6ab5802af 100644
--- a/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch
+++ b/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch
@@ -1,6 +1,6 @@
diff -ur libtheora-1.0beta2.orig/configure.ac libtheora-1.0beta2/configure.ac
---- libtheora-1.0beta2.orig/configure.ac 2007-10-13 00:01:38.000000000 +0300
-+++ libtheora-1.0beta2/configure.ac 2007-11-25 22:44:49.000000000 +0200
+--- a/configure.ac 2007-10-13 00:01:38.000000000 +0300
++++ b/configure.ac 2007-11-25 22:44:49.000000000 +0200
@@ -102,8 +102,8 @@
case $host in
*)
diff --git a/media-libs/libtheora/files/libtheora-1.1.1-fix-UB.patch b/media-libs/libtheora/files/libtheora-1.1.1-fix-UB.patch
new file mode 100644
index 000000000000..862d6a3b8164
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.1.1-fix-UB.patch
@@ -0,0 +1,47 @@
+From 0ae66d565e6bead8604d312bc1a4e9dccf245c88 Mon Sep 17 00:00:00 2001
+From: Tim Terriberry <tterribe@xiph.org>
+Date: Tue, 8 May 2012 02:51:57 +0000
+Subject: [PATCH] Fix pp_sharp_mod calculation.
+
+This was broken when the dequant_tables indexing changed in commit
+ r16102, but it only affected post-processing quality, so we never
+ noticed.
+With gcc 4.8.0, this can now trigger a segfault during decoder
+ initialization.
+
+svn path=/trunk/theora/; revision=18268
+---
+ lib/decode.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+Note: The hunk header was modified from
+
+ @@ -400,10 +400,10 @@
+
+to
+
+ @@ -397,10 +397,10 @@
+
+to match the source code in the libtheora-1.1.1 tar-ball.
+
+diff --git a/lib/decode.c b/lib/decode.c
+index b803505..9f2516a 100644
+--- a/lib/decode.c
++++ b/lib/decode.c
+@@ -397,10 +397,10 @@ static int oc_dec_init(oc_dec_ctx *_dec,const th_info *_info,
+ int qsum;
+ qsum=0;
+ for(qti=0;qti<2;qti++)for(pli=0;pli<3;pli++){
+- qsum+=_dec->state.dequant_tables[qti][pli][qi][12]+
+- _dec->state.dequant_tables[qti][pli][qi][17]+
+- _dec->state.dequant_tables[qti][pli][qi][18]+
+- _dec->state.dequant_tables[qti][pli][qi][24]<<(pli==0);
++ qsum+=_dec->state.dequant_tables[qi][pli][qti][12]+
++ _dec->state.dequant_tables[qi][pli][qti][17]+
++ _dec->state.dequant_tables[qi][pli][qti][18]+
++ _dec->state.dequant_tables[qi][pli][qti][24]<<(pli==0);
+ }
+ _dec->pp_sharp_mod[qi]=-(qsum>>11);
+ }
+--
+2.10.2
diff --git a/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch b/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch
index 93da700c4d7a..46d933323909 100644
--- a/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch
+++ b/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch
@@ -1,8 +1,8 @@
http://bugs.gentoo.org/465450
http://trac.xiph.org/ticket/1947
---- examples/png2theora.c
-+++ examples/png2theora.c
+--- a/examples/png2theora.c
++++ b/examples/png2theora.c
@@ -462,9 +462,9 @@
png_set_strip_alpha(png_ptr);
diff --git a/media-libs/libtheora/files/libtheora-1.1.1-underlinking.patch b/media-libs/libtheora/files/libtheora-1.1.1-underlinking.patch
index b45a368ebd76..7836e3abda23 100644
--- a/media-libs/libtheora/files/libtheora-1.1.1-underlinking.patch
+++ b/media-libs/libtheora/files/libtheora-1.1.1-underlinking.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/504270
---- examples/Makefile.am
-+++ examples/Makefile.am
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
@@ -22,7 +22,7 @@
player_example_SOURCES = player_example.c