summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-22 19:01:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-22 19:01:20 +0200
commit5f2854f539bb4136a9c922d7521675576a3199e3 (patch)
tree287af5a395857b76b9f886ca023b5676f0765176 /media-libs/libtimidity/libtimidity-0.2.4.ebuild
parentsys-devel/ct-ng: remove older version (diff)
downloadgentoo-5f2854f539bb4136a9c922d7521675576a3199e3.tar.gz
gentoo-5f2854f539bb4136a9c922d7521675576a3199e3.tar.bz2
gentoo-5f2854f539bb4136a9c922d7521675576a3199e3.zip
media-libs/libtimidity: bump to 0.2.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-libs/libtimidity/libtimidity-0.2.4.ebuild')
-rw-r--r--media-libs/libtimidity/libtimidity-0.2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libtimidity/libtimidity-0.2.4.ebuild b/media-libs/libtimidity/libtimidity-0.2.4.ebuild
new file mode 100644
index 000000000000..134207fbd89d
--- /dev/null
+++ b/media-libs/libtimidity/libtimidity-0.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit multilib-minimal
+
+DESCRIPTION="MIDI to WAVE converter library"
+HOMEPAGE="http://libtimidity.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ao debug"
+
+RDEPEND="ao? ( >=media-libs/libao-1.1.0-r2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+DOCS="AUTHORS CHANGES TODO README*"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable ao) \
+ $(use_enable debug)
+}