summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-09 12:06:02 -0400
committerMatt Turner <mattst88@gentoo.org>2018-10-09 12:09:04 -0400
commit30969a87e350c5b4de43f63ce980416cab8fd167 (patch)
tree42f67650fec9bd0f6d56bbe2d6e2f041e02a6570 /media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild
parentprofiles: base/make.defaults - Change PHP_TARGETS default (diff)
downloadgentoo-30969a87e350c5b4de43f63ce980416cab8fd167.tar.gz
gentoo-30969a87e350c5b4de43f63ce980416cab8fd167.tar.bz2
gentoo-30969a87e350c5b4de43f63ce980416cab8fd167.zip
media-libs/libtxc_dxtn: Clean up ebuild
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild')
-rw-r--r--media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild
new file mode 100644
index 000000000000..f520acc99906
--- /dev/null
+++ b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Helper library for S3TC texture (de)compression"
+HOMEPAGE="https://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
+SRC_URI="https://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND="media-libs/mesa"
+RDEPEND=""
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ default
+
+ # libtxc_dxtn is installed as a module (plugin)
+ find "${D}" -name '*.la' -delete || die
+}