summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-03-11 22:35:18 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-03-11 23:49:54 +0000
commit7520ba89529789e3c497abf1396c290073a4336e (patch)
tree587f1f12a6ac7bd1777bf92a272e33e4035069c0 /media-libs/libv4l
parentsys-devel/gcc: 9.2.0: cut 6 patchset (diff)
downloadgentoo-7520ba89529789e3c497abf1396c290073a4336e.tar.gz
gentoo-7520ba89529789e3c497abf1396c290073a4336e.tar.bz2
gentoo-7520ba89529789e3c497abf1396c290073a4336e.zip
media-libs/libv4l: add new version 1.18.0
Cloned from 1.16.6 with stable keywords dropped to stable. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'media-libs/libv4l')
-rw-r--r--media-libs/libv4l/Manifest1
-rw-r--r--media-libs/libv4l/libv4l-1.18.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/libv4l/Manifest b/media-libs/libv4l/Manifest
index f4d82f02b5d3..63801100b202 100644
--- a/media-libs/libv4l/Manifest
+++ b/media-libs/libv4l/Manifest
@@ -1,4 +1,5 @@
DIST v4l-utils-1.10.1.tar.bz2 1352235 BLAKE2B 7ececae8ad5ebd999070b0c3626fdf5b0a4bc81562d2c2a712ff9625025d3e6c4ff664ba85998dedaa1ee77295d3cea39306305c20573c07156a07ec0ac8d10a SHA512 524bfd4e93e82f2dd55f0baa3e8be5850d4675b46fd0197b6d1287fc0d502c6b5c64bdf461af9630345f2d847d6aa5b6dc483693cee452da0b6729f156a5d98d
DIST v4l-utils-1.16.3.tar.bz2 1894961 BLAKE2B 71c674abbb3415e592354998e1baa3eedbb4be21757bef80b463ea987e9fc231789e6b333b37d0d9916cb30729e04951dc9f1755ab00a82502fdc415b00cb9a2 SHA512 404672d18d94861c6957ea3a15a6a48f238d3859940810952a5a8cc33b57f1a360d1a19af28405c01b073c0ece90c5995a71dbe6544b30bdb8eace7daeb4bc0b
DIST v4l-utils-1.16.6.tar.bz2 1893768 BLAKE2B f31cf794f6949fa2c1f45db8bae99a10a5fbc67af356889f636ab03cfd04011a82939a10f01145c56001b91655664530cfbda7d64c523752b8bb77159a1c80ab SHA512 f011218591e32b0ca3239373d9ea4739d7cfe3a6bef5f8a996253cea9b9d836ba488132e2a1b8f6f61cd69f1bcecc20e4b5c26f9c95a2a912e17c400b9fa9b58
+DIST v4l-utils-1.18.0.tar.bz2 1995506 BLAKE2B 35cd138c88960e5b02431c408a43905a73ea6a7650a939abc2250e1f219bda1437262a7083d90d8b4d39c5bd2cce5f6fc590b8dc09a8738fb5baf55266256b94 SHA512 749c804671f039d907bf782cba5d1c23fff48066f3b6d4a0249fb9b65c493ee3945b544ee2a306dda79973da04f0301278ee88775f798aba590e5d0f15226d49
DIST v4l-utils-1.6.2.tar.bz2 1148309 BLAKE2B 8153a1e3803b9e59eae064f2c88e4b865a56193788a8cb204dc34e9ae50e66794ba7f020ad4b0ff9af995f57d9b9a9e0225e0f8a09eeefae42d063131d7e549a SHA512 e14442e1b3660d0cb0844f1a5a88f855bc8532df9e72e1b2afd348a7c077ad25657f832d0fd47d3f567bfd399fd82c5a749d075ac9ecb911ea462685e31aa0b2
diff --git a/media-libs/libv4l/libv4l-1.18.0.ebuild b/media-libs/libv4l/libv4l-1.18.0.ebuild
new file mode 100644
index 000000000000..3aa962795920
--- /dev/null
+++ b/media-libs/libv4l/libv4l-1.18.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit libtool linux-info multilib-minimal
+
+MY_P="v4l-utils-${PV}"
+
+DESCRIPTION="Separate libraries ebuild from upstream v4l-utils package"
+HOMEPAGE="https://git.linuxtv.org/v4l-utils.git"
+SRC_URI="https://linuxtv.org/downloads/v4l-utils/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="jpeg"
+
+RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ virtual/libudev[${MULTILIB_USEDEP}]
+ !media-tv/v4l2-ctl
+ !<media-tv/ivtv-utils-1.4.0-r2"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-1.16.6-gcc10-fno-common.patch )
+
+pkg_setup() {
+ CONFIG_CHECK="~SHMEM"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Hard disable the flags that apply only to the utils.
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --disable-qv4l2 \
+ --disable-qvidcap \
+ --disable-v4l-utils \
+ $(use_with jpeg)
+}
+
+multilib_src_compile() {
+ emake -C lib
+}
+
+multilib_src_install() {
+ emake -j1 -C lib DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc ChangeLog README.lib* TODO
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}