summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-09-23 12:25:51 -0400
committerMike Gilbert <floppym@gentoo.org>2016-09-23 12:26:55 -0400
commitacbdb2218f946d8114130f209aecdeb7c627e942 (patch)
treed28e37c98af828af97a034e23a8d269061ea8147 /media-libs/libvpx
parentmedia-libs/libvpx: remove old (diff)
downloadgentoo-acbdb2218f946d8114130f209aecdeb7c627e942.tar.gz
gentoo-acbdb2218f946d8114130f209aecdeb7c627e942.tar.bz2
gentoo-acbdb2218f946d8114130f209aecdeb7c627e942.zip
media-libs/libvpx: port to EAPI 6
Package-Manager: portage-2.3.0_p43
Diffstat (limited to 'media-libs/libvpx')
-rw-r--r--media-libs/libvpx/files/libvpx-1.3.0-sparc-configure.patch4
-rw-r--r--media-libs/libvpx/libvpx-1.6.0-r1.ebuild49
2 files changed, 22 insertions, 31 deletions
diff --git a/media-libs/libvpx/files/libvpx-1.3.0-sparc-configure.patch b/media-libs/libvpx/files/libvpx-1.3.0-sparc-configure.patch
index dc3f6c9387c7..2ddea4d7421f 100644
--- a/media-libs/libvpx/files/libvpx-1.3.0-sparc-configure.patch
+++ b/media-libs/libvpx/files/libvpx-1.3.0-sparc-configure.patch
@@ -1,5 +1,5 @@
---- configure~ 2014-01-10 21:12:42.000000000 +0100
-+++ configure 2014-04-05 12:51:51.794638686 +0200
+--- a/configure
++++ b/configure
@@ -109,6 +109,7 @@
all_platforms="${all_platforms} ppc64-darwin9-gcc"
all_platforms="${all_platforms} ppc64-linux-gcc"
diff --git a/media-libs/libvpx/libvpx-1.6.0-r1.ebuild b/media-libs/libvpx/libvpx-1.6.0-r1.ebuild
index 659cbb70b9f4..7986feb91308 100644
--- a/media-libs/libvpx/libvpx-1.6.0-r1.ebuild
+++ b/media-libs/libvpx/libvpx-1.6.0-r1.ebuild
@@ -2,31 +2,19 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils multilib toolchain-funcs multilib-minimal
+EAPI=6
+inherit toolchain-funcs multilib-minimal
LIBVPX_TESTDATA_VER=1.6.0
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://chromium.googlesource.com/webm/${PN}.git"
-elif [[ ${PV} == *pre* ]]; then
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-else
- SRC_URI="http://storage.googleapis.com/downloads.webmproject.org/releases/webm/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-# generated by: make LIBVPX_TEST_DATA_PATH=libvpx-testdata testdata + tar'ing
-# it.
-SRC_URI="${SRC_URI}
- test? ( mirror://gentoo/${PN}-testdata-${LIBVPX_TESTDATA_VER}.tar.bz2 )"
-
DESCRIPTION="WebM VP8 and VP9 Codec SDK"
HOMEPAGE="http://www.webmproject.org"
+SRC_URI="http://storage.googleapis.com/downloads.webmproject.org/releases/webm/${P}.tar.bz2
+ test? ( mirror://gentoo/${PN}-testdata-${LIBVPX_TESTDATA_VER}.tar.bz2 )"
LICENSE="BSD"
SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="cpu_flags_x86_avx cpu_flags_x86_avx2 doc cpu_flags_x86_mmx postproc cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 +highbitdepth static-libs svc test +threads"
RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
@@ -46,8 +34,19 @@ REQUIRED_USE="
cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
"
-src_prepare() {
- epatch "${FILESDIR}/libvpx-1.3.0-sparc-configure.patch" # 501010
+PATCHES=(
+ "${FILESDIR}/libvpx-1.3.0-sparc-configure.patch" # 501010
+)
+
+src_configure() {
+ # https://bugs.gentoo.org/show_bug.cgi?id=384585
+ # https://bugs.gentoo.org/show_bug.cgi?id=465988
+ # copied from php-pear-r1.eclass
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+ addpredict /var/lib/net-snmp/mib_indexes
+ addpredict /session_mm_cli0.sem
+ multilib-minimal_src_configure
}
multilib_src_configure() {
@@ -61,21 +60,13 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
- # https://bugs.gentoo.org/show_bug.cgi?id=384585
- # https://bugs.gentoo.org/show_bug.cgi?id=465988
- # copied from php-pear-r1.eclass
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/
- addpredict /var/lib/net-snmp/mib_indexes
- addpredict /session_mm_cli0.sem
-
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.
export LD="${CC}"
local myconf
- if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
+ if multilib_is_native_abi; then
myconf+=" $(use_enable doc install-docs) $(use_enable doc docs)"
else
# not needed for multilib and will be overwritten anyway.
@@ -121,5 +112,5 @@ multilib_src_test() {
multilib_src_install() {
emake verbose=yes GEN_EXAMPLES= DESTDIR="${D}" install
- [ "${ABI}" = "${DEFAULT_ABI}" ] && use doc && dohtml docs/html/*
+ multilib_is_native_abi && use doc && dodoc -r docs/html
}