summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libwebp/libwebp-0.4.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libwebp/libwebp-0.4.0.ebuild')
-rw-r--r--media-libs/libwebp/libwebp-0.4.0.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/libwebp/libwebp-0.4.0.ebuild b/media-libs/libwebp/libwebp-0.4.0.ebuild
new file mode 100644
index 000000000000..ba40ca057a3f
--- /dev/null
+++ b/media-libs/libwebp/libwebp-0.4.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="A lossy image compression format"
+HOMEPAGE="http://code.google.com/p/webp/"
+SRC_URI="http://webp.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/5" # subslot = libwebp soname version
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~m68k-mint"
+IUSE="experimental gif +jpeg opengl +png static-libs swap-16bit-csp tiff"
+
+# TODO: dev-lang/swig bindings in swig/ subdirectory
+RDEPEND="gif? ( media-libs/giflib:= )
+ jpeg? ( virtual/jpeg:0= )
+ opengl? (
+ media-libs/freeglut
+ virtual/opengl
+ )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}"
+
+ECONF_SOURCE=${S}
+
+src_prepare() {
+ # This is conflicting with `usex` later on, upstream is using ac_cv_ wrong
+ # If modifying configure.ac, eautoreconf is required because of "Maintainer mode"
+ sed -i -e '/unset ac_cv_header_GL_glut_h/d' configure || die
+
+ # Fix libtool relinking, bug 499270.
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Only used for gif2webp binary wrt #486646
+ local build_gif2webp=$(usex gif)
+ multilib_is_native_abi || build_gif2webp=no
+
+ ac_cv_header_gif_lib_h=${build_gif2webp} \
+ ac_cv_header_jpeglib_h=$(usex jpeg) \
+ ac_cv_header_png_h=$(usex png) \
+ ac_cv_header_GL_glut_h=$(usex opengl) \
+ ac_cv_header_tiffio_h=$(usex tiff) \
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable swap-16bit-csp) \
+ $(use_enable experimental) \
+ --enable-libwebpmux \
+ --enable-libwebpdemux \
+ --enable-libwebpdecoder
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README{,.mux}
+}