summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-24 22:44:11 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-02 00:08:35 +0200
commit4c50f6a78847e466c4233fb99564f4fd0064c647 (patch)
tree0079b2fd66811592b6cd21b58d951540a157e752 /media-libs/libzmf
parentapp-text/libstaroffice: New package (diff)
downloadgentoo-4c50f6a78847e466c4233fb99564f4fd0064c647.tar.gz
gentoo-4c50f6a78847e466c4233fb99564f4fd0064c647.tar.bz2
gentoo-4c50f6a78847e466c4233fb99564f4fd0064c647.zip
media-libs/libzmf: New package
Required by >=app-office/libreoffice-5.3 Gentoo-bug: 587980 Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/libzmf')
-rw-r--r--media-libs/libzmf/libzmf-9999.ebuild52
-rw-r--r--media-libs/libzmf/metadata.xml11
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libzmf/libzmf-9999.ebuild b/media-libs/libzmf/libzmf-9999.ebuild
new file mode 100644
index 000000000000..12a383650275
--- /dev/null
+++ b/media-libs/libzmf/libzmf-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://gerrit.libreoffice.org/libzmf"
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit eutils ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Library for parsing Zoner Callisto/Draw documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libzmf"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libzmf/metadata.xml b/media-libs/libzmf/metadata.xml
new file mode 100644
index 000000000000..9a942b1970c0
--- /dev/null
+++ b/media-libs/libzmf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Build conversion tools</flag>
+ </use>
+</pkgmetadata>