summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornado <nado@troglodyte.be>2018-07-11 09:50:17 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-12 13:59:10 -0500
commit6d0bfbcf4988e474a5c31ea2485501e66f95680b (patch)
tree0d778922086bddd9ce53090e70cc9a5c844126ea /media-libs/lilv/lilv-0.24.2-r3.ebuild
parentmedia-plugins/calf: set $EPREFIX where needed in econf call (diff)
downloadgentoo-6d0bfbcf4988e474a5c31ea2485501e66f95680b.tar.gz
gentoo-6d0bfbcf4988e474a5c31ea2485501e66f95680b.tar.bz2
gentoo-6d0bfbcf4988e474a5c31ea2485501e66f95680b.zip
media-libs/lilv: add env file to ease prefix support
LV2_PATH is checked by lilv tools to find lv2 plugins It is necessary to specify its path in prefix installs Package-Manager: Portage-2.3.41, Repoman-2.3.9 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-libs/lilv/lilv-0.24.2-r3.ebuild')
-rw-r--r--media-libs/lilv/lilv-0.24.2-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/lilv/lilv-0.24.2-r3.ebuild b/media-libs/lilv/lilv-0.24.2-r3.ebuild
new file mode 100644
index 000000000000..9b5c50d8fcf3
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.2-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils bash-completion-r1 multilib-build multilib-minimal
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="doc +dyn-manifest static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.14.0-r1[${MULTILIB_USEDEP}]
+ >=media-libs/sratom-0.6.0-r1[${MULTILIB_USEDEP}]
+ >=dev-libs/serd-0.28.0-r1[${MULTILIB_USEDEP}]
+ >=dev-libs/sord-0.16.0-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ eapply "${FILESDIR}/includedir.patch"
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --no-bash-completion \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "") \
+ $(usex dyn-manifest --dyn-manifest "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}
+
+multilib_src_install_all() {
+ newbashcomp utils/lilv.bash_completion ${PN}
+ dodir /etc/env.d
+ echo "LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2" > "${ED}/etc/env.d/60lv2"
+}