summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2020-06-18 16:55:29 +0200
committerMatt Turner <mattst88@gentoo.org>2020-08-11 12:42:15 -0700
commit4d3c82abc28301dd617780a210b8652fb288ab07 (patch)
tree9831025f15dfb62136907ee58e2e3c87dde2d4c9 /media-libs/mesa/mesa-9999.ebuild
parentdev-libs/libgnt: USE="doc" requires dev-util/gtk-doc (diff)
downloadgentoo-4d3c82abc28301dd617780a210b8652fb288ab07.tar.gz
gentoo-4d3c82abc28301dd617780a210b8652fb288ab07.tar.bz2
gentoo-4d3c82abc28301dd617780a210b8652fb288ab07.zip
media-libs/mesa: Enable Zink OpenGL-over-Vulkan gallium driver
Run "MESA_LOADER_DRIVER_OVERRIDE=zink glxinfo" to view OpenGL features supported by the Zink driver. Closes: https://bugs.gentoo.org/708838 Closes: https://github.com/gentoo/gentoo/pull/16309 Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 36c5b235d2df..311d46e53a90 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -37,7 +37,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +libglvnd +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
- vulkan-overlay wayland +X xa xvmc +zstd"
+ vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -68,6 +68,7 @@ REQUIRED_USE="
video_cards_vmware? ( gallium )
xa? ( X )
xvmc? ( X )
+ zink? ( gallium vulkan )
"
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.100"
@@ -127,6 +128,7 @@ RDEPEND="
>=x11-libs/libxcb-1.13:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
)
+ zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
for card in ${RADEON_CARDS}; do
@@ -439,6 +441,7 @@ multilib_src_configure() {
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
+ gallium_enable zink zink
# Only one i915 driver (classic vs gallium). Default to classic.
if ! use classic; then