summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-02-09 11:45:12 -0800
committerMatt Turner <mattst88@gentoo.org>2016-02-09 11:54:55 -0800
commit6a92ea7c1d3352394094f47440f6dd2645b4d3da (patch)
tree4ccf53f23b6930ee222dc13d0daa23e488ff78d6 /media-libs/mesa/mesa-9999.ebuild
parentmedia-video/vlc: Fixed compilation with qt5 (bug #574256). (diff)
downloadgentoo-6a92ea7c1d3352394094f47440f6dd2645b4d3da.tar.gz
gentoo-6a92ea7c1d3352394094f47440f6dd2645b4d3da.tar.bz2
gentoo-6a92ea7c1d3352394094f47440f6dd2645b4d3da.zip
media-libs/mesa: Build gallium-osmesa when USE="gallium osmesa"
With only USE=osmesa, build the classic OSMesa. Bug: https://bugs.gentoo.org/574070
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 3a58ccc2d790..8785e9d870e7 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -274,6 +274,12 @@ multilib_src_configure() {
myconf+=" --disable-asm"
fi
+ if use gallium; then
+ myconf+=" $(use_enable osmesa gallium-osmesa)"
+ else
+ myconf+=" $(use_enable osmesa)"
+ fi
+
# build fails with BSD indent, bug #428112
use userland_GNU || export INDENT=cat
@@ -292,7 +298,6 @@ multilib_src_configure() {
$(use_enable gles1) \
$(use_enable gles2) \
$(use_enable nptl glx-tls) \
- $(use_enable osmesa) \
$(use_enable !udev sysfs) \
--enable-llvm-shared-libs \
--with-dri-drivers=${DRI_DRIVERS} \