summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-25 14:27:34 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-25 14:35:39 -0700
commit1ef1b1f83c095b4d59dc8e9c822df6dbeb40bdca (patch)
tree36c7176d7ce42ffa5e98b1bea32bcf76ac0af2de /media-libs/mesa
parentapp-misc/ktoblzcheck: EAPI-7 bump, fix REQUIRED_USE (diff)
downloadgentoo-1ef1b1f83c095b4d59dc8e9c822df6dbeb40bdca.tar.gz
gentoo-1ef1b1f83c095b4d59dc8e9c822df6dbeb40bdca.tar.bz2
gentoo-1ef1b1f83c095b4d59dc8e9c822df6dbeb40bdca.zip
media-libs/mesa: Fix more libglvnd issues
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-19.2.0.ebuild11
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
2 files changed, 16 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-19.2.0.ebuild b/media-libs/mesa/mesa-19.2.0.ebuild
index 53a94beb6089..27301deb54b0 100644
--- a/media-libs/mesa/mesa-19.2.0.ebuild
+++ b/media-libs/mesa/mesa-19.2.0.ebuild
@@ -243,6 +243,7 @@ x86? (
usr/lib*/libGLESv2.so.2.0.0
usr/lib*/libGL.so.1.2.0
usr/lib*/libOSMesa.so.8.0.0
+ libglvnd? ( usr/lib/libGLX_mesa.so.0.0.0 )
)"
llvm_check_deps() {
@@ -503,6 +504,8 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
+
+ use libglvnd && rm -f "${D}"/usr/$(get_libdir)/pkgconfig/{egl,gl}.pc
}
multilib_src_install_all() {
@@ -514,9 +517,11 @@ multilib_src_test() {
}
pkg_postinst() {
- # Switch to the xorg implementation.
- echo
- eselect opengl set --use-old ${OPENGL_DIR}
+ if ! use libglvnd; then
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+ fi
}
# $1 - VIDEO_CARDS flag (check skipped for "--")
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 53a94beb6089..27301deb54b0 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -243,6 +243,7 @@ x86? (
usr/lib*/libGLESv2.so.2.0.0
usr/lib*/libGL.so.1.2.0
usr/lib*/libOSMesa.so.8.0.0
+ libglvnd? ( usr/lib/libGLX_mesa.so.0.0.0 )
)"
llvm_check_deps() {
@@ -503,6 +504,8 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
+
+ use libglvnd && rm -f "${D}"/usr/$(get_libdir)/pkgconfig/{egl,gl}.pc
}
multilib_src_install_all() {
@@ -514,9 +517,11 @@ multilib_src_test() {
}
pkg_postinst() {
- # Switch to the xorg implementation.
- echo
- eselect opengl set --use-old ${OPENGL_DIR}
+ if ! use libglvnd; then
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+ fi
}
# $1 - VIDEO_CARDS flag (check skipped for "--")