summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-07 10:34:28 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-07 11:02:50 -0800
commit43aaa07b64432fdc21b5a2f68716189f7991a592 (patch)
tree1c36148d03f34a291658f152200543c7aacadcc1 /media-libs/mesa
parentmedia-libs/mesa: Fix egl/gbm enables (diff)
downloadgentoo-43aaa07b64432fdc21b5a2f68716189f7991a592.tar.gz
gentoo-43aaa07b64432fdc21b5a2f68716189f7991a592.tar.bz2
gentoo-43aaa07b64432fdc21b5a2f68716189f7991a592.zip
media-libs/mesa: Readd IUSE="egl gbm" to 21.3.5
Closes: https://bugs.gentoo.org/828491 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-21.3.5.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-21.3.5.ebuild b/media-libs/mesa/mesa-21.3.5.ebuild
index 7b064418bfbd..fc79dd1e10e0 100644
--- a/media-libs/mesa/mesa-21.3.5.ebuild
+++ b/media-libs/mesa/mesa-21.3.5.ebuild
@@ -33,15 +33,18 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic cpu_flags_x86_sse2 d3d9 debug +gallium gles1 +gles2 +llvm
+ +classic cpu_flags_x86_sse2 d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
d3d9? ( || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
+ gles1? ( egl )
+ gles2? ( egl )
osmesa? ( gallium )
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
+ wayland? ( egl gbm )
video_cards_crocus? ( gallium )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
@@ -61,7 +64,7 @@ REQUIRED_USE="
video_cards_v3d? ( gallium )
video_cards_vc4? ( gallium )
video_cards_virgl? ( gallium )
- video_cards_vivante? ( gallium )
+ video_cards_vivante? ( gallium gbm )
video_cards_vmware? ( gallium )
xa? ( X )
xvmc? ( X )
@@ -381,6 +384,12 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
emesonargs+=(-Dplatforms=${platforms#,})
+ if use X || use egl; then
+ emesonargs+=(-Dglvnd=true)
+ else
+ emesonargs+=(-Dglvnd=false)
+ fi
+
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -503,9 +512,8 @@ multilib_src_configure() {
-Dglx=$(usex X dri disabled)
-Dshared-glapi=enabled
-Ddri3=enabled
- -Degl=true
- -Dgbm=true
- -Dglvnd=true
+ $(meson_feature egl)
+ $(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)
$(meson_use osmesa)