summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-15 15:49:17 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-15 15:52:02 -0700
commit559136967423b703801d9cdf0b692e5d9b779fff (patch)
tree817b5204c958010b496cfa443f13124f397a67c4 /media-libs/mesa
parentprofiles: Add panfrost and lima descriptions and use masks (diff)
downloadgentoo-559136967423b703801d9cdf0b692e5d9b779fff.tar.gz
gentoo-559136967423b703801d9cdf0b692e5d9b779fff.tar.bz2
gentoo-559136967423b703801d9cdf0b692e5d9b779fff.zip
media-libs/mesa: Add lima and panfrost
panfrost should be usable in mesa-19.2. Closes: https://bugs.gentoo.org/686218 Closes: https://bugs.gentoo.org/687896 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index b45409f64da6..de737e259d61 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -30,7 +30,7 @@ RESTRICT="
"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris nouveau vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris lima nouveau panfrost vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -54,7 +54,9 @@ REQUIRED_USE="
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
video_cards_iris? ( gallium )
+ video_cards_lima? ( gallium )
video_cards_nouveau? ( || ( classic gallium ) )
+ video_cards_panfrost? ( gallium )
video_cards_radeon? ( || ( classic gallium )
gallium? ( x86? ( llvm ) amd64? ( llvm ) ) )
video_cards_r100? ( classic )
@@ -401,11 +403,15 @@ multilib_src_configure() {
fi
if use video_cards_freedreno ||
+ use video_cards_lima ||
+ use video_cards_panfrost ||
use video_cards_vc4 ||
use video_cards_vivante; then
gallium_enable -- kmsro
fi
+ gallium_enable video_cards_lima lima
+ gallium_enable video_cards_panfrost panfrost
gallium_enable video_cards_vc4 vc4
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga