summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-10 14:33:31 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-10 14:53:36 -0500
commit7c338fc7b6fa1c7058cb06ca240642b33933a33b (patch)
tree14791b07e7b333de1341f7ea82c823615c338ee9 /media-libs/mesa
parentnet-proxy/haproxy: introduce subslots (diff)
downloadgentoo-7c338fc7b6fa1c7058cb06ca240642b33933a33b.tar.gz
gentoo-7c338fc7b6fa1c7058cb06ca240642b33933a33b.tar.bz2
gentoo-7c338fc7b6fa1c7058cb06ca240642b33933a33b.zip
media-libs/mesa: Remove classic OSMesa support
Was removed upstream in commit ee802372180a (mesa: Retire classic OSMesa.). media-libs/mesa[osmesa] now requires USE=gallium, and it is recommended to enable USE=llvm for better performance. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 2e217a5233af..5c410fcd9811 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -43,6 +43,7 @@ REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
gles1? ( egl )
gles2? ( egl )
+ osmesa? ( gallium )
vulkan? ( dri3
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
@@ -316,6 +317,10 @@ pkg_pretend() {
if ! use llvm; then
use opencl && ewarn "Ignoring USE=opencl since USE does not contain llvm"
fi
+
+ if use osmesa && ! use llvm; then
+ ewarn "OSMesa will be slow without enabling USE=llvm"
+ fi
}
python_check_deps() {
@@ -346,6 +351,8 @@ multilib_src_configure() {
local emesonargs=()
if use classic; then
+ dri_driver_enable !gallium swrast
+
# Intel code
dri_driver_enable video_cards_i915 i915
dri_driver_enable video_cards_i965 i965
@@ -437,6 +444,7 @@ multilib_src_configure() {
gallium_enable -- kmsro
fi
+ gallium_enable -- swrast
gallium_enable video_cards_lima lima
gallium_enable video_cards_panfrost panfrost
gallium_enable video_cards_v3d v3d
@@ -481,14 +489,6 @@ multilib_src_configure() {
vulkan_enable video_cards_v3d broadcom
fi
- if use gallium; then
- gallium_enable -- swrast
- emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )
- else
- dri_driver_enable -- swrast
- emesonargs+=( -Dosmesa=$(usex osmesa classic none) )
- fi
-
driver_list() {
local drivers="$(sort -u <<< "${1// /$'\n'}")"
echo "${drivers//$'\n'/,}"
@@ -503,6 +503,7 @@ multilib_src_configure() {
$(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)
+ $(meson_use osmesa)
$(meson_use selinux)
$(meson_feature zstd)
-Dvalgrind=$(usex valgrind auto false)