summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/nas/nas-1.9.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/nas/nas-1.9.4-r1.ebuild')
-rw-r--r--media-libs/nas/nas-1.9.4-r1.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/nas/nas-1.9.4-r1.ebuild b/media-libs/nas/nas-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..69107ee54529
--- /dev/null
+++ b/media-libs/nas/nas-1.9.4-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="Network Audio System"
+HOMEPAGE="http://radscan.com/nas.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="HPND MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-text/rman
+ sys-devel/bison
+ sys-devel/flex
+ x11-misc/gccmakedep
+ x11-misc/imake
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+
+DOCS=( BUILDNOTES FAQ HISTORY README RELEASE TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9.2-asneeded.patch
+ epatch "${FILESDIR}"/${PN}-1.9.4-remove-abs-fabs.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ xmkmf -a || die
+}
+
+multilib_src_compile() {
+ # EXTRA_LDOPTIONS, SHLIBGLOBALSFLAGS #336564#c2
+ local emakeopts=(
+ AR="$(tc-getAR) clq"
+ AS="$(tc-getAS)"
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ CXX="$(tc-getCXX)"
+ CXXDEBUFLAGS="${CXXFLAGS}"
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+ LD="$(tc-getLD)"
+ MAKE="${MAKE:-gmake}"
+ RANLIB="$(tc-getRANLIB)"
+ SHLIBGLOBALSFLAGS="${LDFLAGS}"
+ WORLDOPTS=
+ )
+
+ if multilib_is_native_abi ; then
+ # dumb fix for parallel make issue wrt #446598, Imake sux
+ emake "${emakeopts[@]}" -C server/dia all
+ emake "${emakeopts[@]}" -C server/dda/voxware all
+ emake "${emakeopts[@]}" -C server/os all
+ else
+ sed -i \
+ -e 's/SUBDIRS =.*/SUBDIRS = include lib config/' \
+ Makefile || die
+ fi
+
+ emake "${emakeopts[@]}" World
+}
+
+multilib_src_install() {
+ # ranlib is used at install phase too wrt #446600
+ emake RANLIB="$(tc-getRANLIB)" \
+ DESTDIR="${D}" USRLIBDIR=/usr/$(get_libdir) \
+ install install.man
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc; then
+ docinto doc
+ dodoc doc/{actions,protocol.txt,README}
+ docinto pdf
+ dodoc doc/pdf/*.pdf
+ fi
+
+ mv -vf "${D}"/etc/nas/nasd.conf{.eg,} || die
+
+ newconfd "${FILESDIR}"/nas.conf.d nas
+ newinitd "${FILESDIR}"/nas.init.d nas
+
+ use static-libs || rm -f "${D}"/usr/lib*/libaudio.a
+}