summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-07-08 19:22:52 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-08 21:57:40 -0400
commit04d723efb22e209a20a44395ae688edbcdd442ee (patch)
tree8eda016f74283d0233d571d9b744c8198d3494e0 /media-libs/opencollada
parentmedia-libs/opencollada: Remove live ebuild as it's no longer needed (diff)
downloadgentoo-04d723efb22e209a20a44395ae688edbcdd442ee.tar.gz
gentoo-04d723efb22e209a20a44395ae688edbcdd442ee.tar.bz2
gentoo-04d723efb22e209a20a44395ae688edbcdd442ee.zip
media-libs/opencollada: Rev bump to fix insecure runpath vulnerability
Closes Gentoo Bug 439530 Also, remove live ebuild logic
Diffstat (limited to 'media-libs/opencollada')
-rw-r--r--media-libs/opencollada/opencollada-1.6.18-r1.ebuild (renamed from media-libs/opencollada/opencollada-1.6.18.ebuild)24
1 files changed, 13 insertions, 11 deletions
diff --git a/media-libs/opencollada/opencollada-1.6.18.ebuild b/media-libs/opencollada/opencollada-1.6.18-r1.ebuild
index 53164b4c132d..028f63147757 100644
--- a/media-libs/opencollada/opencollada-1.6.18.ebuild
+++ b/media-libs/opencollada/opencollada-1.6.18-r1.ebuild
@@ -4,20 +4,16 @@
EAPI=6
-EGIT_REPO_URI="https://github.com/KhronosGroup/OpenCOLLADA.git"
-inherit multilib cmake-utils
-[[ ${PV} == "9999" ]] && inherit git-r3
+inherit eutils cmake-utils
DESCRIPTION="Stream based read/write library for COLLADA files"
HOMEPAGE="http://www.opencollada.org/"
-[[ ${PV} == "9999" ]] || \
- SRC_URI="https://github.com/KhronosGroup/OpenCOLLADA/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/KhronosGroup/OpenCOLLADA/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-[[ ${PV} == "9999" ]] || \
- KEYWORDS="~amd64 ~ppc64 ~x86" \
- S="${WORKDIR}"/OpenCOLLADA-${PV}
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="expat static-libs"
@@ -30,8 +26,10 @@ RDEPEND="dev-libs/libpcre
sys-libs/zlib
expat? ( dev-libs/expat )
!expat? ( dev-libs/libxml2 )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+S="${WORKDIR}"/OpenCOLLADA-${PV}
# This is needed or you get an error on install
BUILD_DIR="${S}"/build
@@ -53,6 +51,10 @@ src_prepare() {
# Remove unused build systems
rm Makefile scripts/{unixbuild.sh,vcproj2cmake.rb} || die
find "${S}" -name SConscript -delete || die
+
+ # Fix insecure RUNPATHS vulnerability
+ sed '/link_directories/i SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)' \
+ -i COLLADAValidator/CMakeLists.txt || die "sed failed"
}
src_configure() {
@@ -70,8 +72,8 @@ src_configure() {
src_install() {
cmake-utils_src_install
- echo "LDPATH=/usr/$(get_libdir)/opencollada" > "${T}"/99${PN}; \
- doenvd "${T}"/99${PN}
+ echo "LDPATH=/usr/$(get_libdir)/opencollada" > "${T}"/99${PN} || die "echo failed"
+ doenvd "${T}"/99${PN}
dobin build/bin/OpenCOLLADAValidator
}