summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-10 13:35:26 +0000
committerSam James <sam@gentoo.org>2020-10-10 13:35:39 +0000
commit4751ed3cfef4736ce6684af0b677f744e3fffe0f (patch)
tree64d53f11fccfd23e3a3937188ef898fa42753874 /media-libs/opencolorio
parentsci-astronomy/stellarium: fix patches (diff)
downloadgentoo-4751ed3cfef4736ce6684af0b677f744e3fffe0f.tar.gz
gentoo-4751ed3cfef4736ce6684af0b677f744e3fffe0f.tar.bz2
gentoo-4751ed3cfef4736ce6684af0b677f744e3fffe0f.zip
media-libs/opencolorio: drop useless Boost check
We don't actually need Boost; upstream were checking on behalf of yaml-cpp, which doesn't need Boost anymore anyway, but it wouldn't have been opencolorio's responsibility for it even if it did. This test has since been dropped upstream. Closes: https://bugs.gentoo.org/747553 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/opencolorio')
-rw-r--r--media-libs/opencolorio/files/opencolorio-1.1.1-yaml-cpp-boost-check.patch35
-rw-r--r--media-libs/opencolorio/opencolorio-1.1.1.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/opencolorio/files/opencolorio-1.1.1-yaml-cpp-boost-check.patch b/media-libs/opencolorio/files/opencolorio-1.1.1-yaml-cpp-boost-check.patch
new file mode 100644
index 000000000000..0f3c3e3ba19b
--- /dev/null
+++ b/media-libs/opencolorio/files/opencolorio-1.1.1-yaml-cpp-boost-check.patch
@@ -0,0 +1,35 @@
+This check is redundant. The appropriate versions of yaml-cpp
+already had a dependency on Boost, but that's not even the case anymore.
+
+Check has been dropped upstream since.
+https://bugs.gentoo.org/747553
+----
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eb20913..434e38b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -272,24 +272,6 @@ if(USE_EXTERNAL_YAML)
+ mark_as_advanced(YAML_CPP_INCLUDE_DIR YAML_CPP_LIBRARY YAML-CPP_FOUND)
+
+ if(YAML_CPP_FOUND)
+- if(YAML_CPP_VERSION VERSION_GREATER "0.5.0")
+- # Need to also get the boost headers here, as yaml-cpp 0.5.0+ requires them.
+- # Don't bother doing this step if we are already including the boost headers for shared_ptr
+- if(NOT OCIO_USE_BOOST_PTR)
+- set(Boost_ADDITIONAL_VERSIONS "1.49" "1.45" "1.44" "1.43" "1.43.0" "1.42"
+- "1.42.0" "1.41" "1.41.0" "1.40"
+- "1.40.0" "1.39" "1.39.0" "1.38"
+- "1.38.0" "1.37" "1.37.0" "1.34.1"
+- "1_34_1")
+- set(Boost_USE_MULTITHREADED ON)
+- find_package(Boost 1.34)
+- if(NOT Boost_FOUND)
+- message(FATAL_ERROR "Error: Detected system yaml-cpp version ${YAML_CPP_VERSION} is greater than 0.5.0, and therefore requires boost, but a boost installation could not be found.")
+- endif()
+-
+- set(EXTERNAL_INCLUDE_DIRS ${EXTERNAL_INCLUDE_DIRS} ${Boost_INCLUDE_DIR})
+- endif()
+- endif()
+ set(EXTERNAL_INCLUDE_DIRS ${EXTERNAL_INCLUDE_DIRS} ${YAML_CPP_INCLUDE_DIRS})
+ else(YAML_CPP_FOUND)
+ message(FATAL_ERROR "ERROR: System yaml-cpp library was not found. Make sure the library is installed and the pkg-config file exists.")
diff --git a/media-libs/opencolorio/opencolorio-1.1.1.ebuild b/media-libs/opencolorio/opencolorio-1.1.1.ebuild
index 9b3802a51da5..9b6bcb993bea 100644
--- a/media-libs/opencolorio/opencolorio-1.1.1.ebuild
+++ b/media-libs/opencolorio/opencolorio-1.1.1.ebuild
@@ -51,6 +51,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.1.0-remove-building-of-bundled-programs.patch"
"${FILESDIR}/${PN}-1.1.0-yaml-cpp-0.6.patch"
"${FILESDIR}/${PN}-1.1.0-remove-Werror.patch"
+ "${FILESDIR}/${PN}-1.1.1-yaml-cpp-boost-check.patch"
)
pkg_setup() {