summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-10-09 19:02:45 +0100
committerDavid Seifert <soap@gentoo.org>2016-10-11 00:25:55 +0200
commit9d9485b2bcb02cfd80680e6949a9f7e303687311 (patch)
treec86b4b081c2e733e0750ba548cc1361e9e1e1d22 /media-libs/openexr/openexr-2.2.0-r1.ebuild
parentnet-mail/notmuch: Bump version to 0.23 (diff)
downloadgentoo-9d9485b2bcb02cfd80680e6949a9f7e303687311.tar.gz
gentoo-9d9485b2bcb02cfd80680e6949a9f7e303687311.tar.bz2
gentoo-9d9485b2bcb02cfd80680e6949a9f7e303687311.zip
media-libs/openexr: revision bump to fix various build errors
Gentoo-bug: 520648, 585846 * EAPI=6 * Port to 'multilib-minimal' * Fix build system to not require blocker * Remove .la files Signed off by: Jonathan Scruggs (j.scruggs@gmail.com, irc: Dracwyrm) Closes: https://github.com/gentoo/gentoo/pull/2520 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/openexr/openexr-2.2.0-r1.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.2.0-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/openexr/openexr-2.2.0-r1.ebuild b/media-libs/openexr/openexr-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..8fd2d9961505
--- /dev/null
+++ b/media-libs/openexr/openexr-2.2.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/22" # based on SONAME
+KEYWORDS="~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cpu_flags_x86_avx examples static-libs"
+
+RDEPEND="
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/autoconf-archive-2016.09.16"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-cpuid-on-abi_x86_32.patch"
+ "${FILESDIR}/${P}-use-ull-for-64-bit-literals.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
+ "${FILESDIR}/${P}-fix-config.h-collision.patch"
+)
+
+src_prepare() {
+ default
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" IlmImfTest/tmpDir.h || die
+
+ # delete stray config files causing havoc
+ rm -f config*/OpenEXRConfig.h* || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-threading \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable static-libs static) \
+ $(use_enable examples imfexamples)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ docompress -x /usr/share/doc/${PF}/examples
+ if ! use examples; then
+ rm -rf "${ED%/}"/usr/share/doc/${PF}/examples || die
+ fi
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}