summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-23 14:04:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-09-28 14:45:07 +0200
commitdd4ad81b5d8ba426b3d2d75b27f9993119f73e30 (patch)
tree37364d9ee45184e0e3740d3d7fa5c20972152171 /media-libs/openexr/openexr-2.2.0-r2.ebuild
parentmedia-libs/ilmbase: Revision bump to 2.2.0-r1 (diff)
downloadgentoo-dd4ad81b5d8ba426b3d2d75b27f9993119f73e30.tar.gz
gentoo-dd4ad81b5d8ba426b3d2d75b27f9993119f73e30.tar.bz2
gentoo-dd4ad81b5d8ba426b3d2d75b27f9993119f73e30.zip
media-libs/openexr: Revision bump to 2.2.0-r2
* Added patch to fix a typo in the C bindings * Added patch to install the missing header files * Added patch to fix security issues: CVE-2017-9110, CVE-2017-9111, CVE-2017-9112, CVE-2017-9113, CVE-2017-9114, CVE-2017-9115, CVE-2017-9116 * Fixed build system patch * Added tabs in the metadata.xml file Closes: https://bugs.gentoo.org/616996 Closes: https://bugs.gentoo.org/631382 Closes: https://bugs.gentoo.org/620324
Diffstat (limited to 'media-libs/openexr/openexr-2.2.0-r2.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.2.0-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/openexr/openexr-2.2.0-r2.ebuild b/media-libs/openexr/openexr-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..91e85f36c2b7
--- /dev/null
+++ b/media-libs/openexr/openexr-2.2.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/22" # based on SONAME
+KEYWORDS="~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cpu_flags_x86_avx examples static-libs"
+
+RDEPEND="
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ >=sys-devel/autoconf-archive-2016.09.16"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-cpuid-on-abi_x86_32.patch"
+ "${FILESDIR}/${P}-use-ull-for-64-bit-literals.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
+ "${FILESDIR}/${P}-fix-config.h-collision.patch"
+ "${FILESDIR}/${P}-Fix-typo-in-C-bindings.patch"
+ "${FILESDIR}/${P}-Install-missing-header-files.patch"
+ "${FILESDIR}/${P}-CVE-2017-9110-to-9116-security-fixes.patch"
+)
+
+src_prepare() {
+ default
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" IlmImfTest/tmpDir.h || die
+
+ # delete stray config files causing havoc
+ rm -f config*/OpenEXRConfig.h* || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-threading \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable static-libs static) \
+ $(use_enable examples imfexamples)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${ED%/}"/usr/share/doc/${PF}/examples || die
+ fi
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}