summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/openexr_ctl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/openexr_ctl/files')
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-configure_gcc43.patch22
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc43.patch34
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch11
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch18
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch12
5 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-configure_gcc43.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-configure_gcc43.patch
new file mode 100644
index 000000000000..604d4237458d
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-configure_gcc43.patch
@@ -0,0 +1,22 @@
+diff -up openexr_ctl-1.0.1/configure.conf_gcc43 openexr_ctl-1.0.1/configure
+--- openexr_ctl-1.0.1/configure.conf_gcc43 2008-01-09 17:08:57.000000000 +0100
++++ openexr_ctl-1.0.1/configure 2008-01-09 17:10:25.000000000 +0100
+@@ -20851,6 +20851,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+
+ #include <CtlSimdInterpreter.h>
+ #include <Iex.h>
++#include <cstdlib>
+
+ int
+ main ()
+diff -up openexr_ctl-1.0.1/configure.ac.conf_gcc43 openexr_ctl-1.0.1/configure.ac
+--- openexr_ctl-1.0.1/configure.ac.conf_gcc43 2008-01-09 17:11:25.000000000 +0100
++++ openexr_ctl-1.0.1/configure.ac 2008-01-09 17:12:17.000000000 +0100
+@@ -108,6 +108,7 @@ AM_COMPILELINKRUN(
+ [$CTL_LIBS],[[
+ #include <CtlSimdInterpreter.h>
+ #include <Iex.h>
++#include <cstdlib>
+ ]],
+ [[Ctl::SimdInterpreter interp; interp.setMaxInstCount(10);]],
+ AC_MSG_RESULT([The ctl test program succeeded.]),
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc43.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc43.patch
new file mode 100644
index 000000000000..349d4f083ca6
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc43.patch
@@ -0,0 +1,34 @@
+diff -up openexr_ctl-1.0.1/exrdpx/main.cpp.gcc43 openexr_ctl-1.0.1/exrdpx/main.cpp
+--- openexr_ctl-1.0.1/exrdpx/main.cpp.gcc43 2007-07-25 08:28:17.000000000 +0200
++++ openexr_ctl-1.0.1/exrdpx/main.cpp 2008-01-08 20:27:14.000000000 +0100
+@@ -60,6 +60,8 @@
+ #include <iostream>
+ #include <string>
+ #include <exception>
++#include <cstdlib>
++#include <cstring>
+
+ using namespace std;
+ using namespace Imf;
+diff -up openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp.gcc43 openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp
+--- openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp.gcc43 2008-01-08 20:30:30.000000000 +0100
++++ openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp 2008-01-08 20:33:02.000000000 +0100
+@@ -64,6 +64,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <string>
++#include <cstdlib>
+
+ using namespace std;
+ using namespace Ctl;
+diff -up openexr_ctl-1.0.1/exr_ctl_exr/main.cpp.gcc43 openexr_ctl-1.0.1/exr_ctl_exr/main.cpp
+--- openexr_ctl-1.0.1/exr_ctl_exr/main.cpp.gcc43 2008-01-08 20:34:32.000000000 +0100
++++ openexr_ctl-1.0.1/exr_ctl_exr/main.cpp 2008-01-08 20:35:10.000000000 +0100
+@@ -59,6 +59,7 @@
+ #include <iostream>
+ #include <string>
+ #include <exception>
++#include <cstdlib>
+ #include <ImfFloatAttribute.h>
+ #include <ImfVecAttribute.h>
+
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch
new file mode 100644
index 000000000000..08530bdeaad3
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur openexr_ctl-1.0.1.orig/exr_ctl_exr/applyCtl.cpp openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp
+--- openexr_ctl-1.0.1.orig/exr_ctl_exr/applyCtl.cpp 2007-07-13 06:24:37.000000000 +0300
++++ openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp 2009-07-30 11:46:29.000000000 +0300
+@@ -60,6 +60,7 @@
+ #include <ImfStandardAttributes.h>
+ #include <ImfHeader.h>
+ #include <ImfFrameBuffer.h>
++#include <cstdio>
+ #include <cassert>
+ #include <iostream>
+ #include <vector>
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch
new file mode 100644
index 000000000000..7c30515f122d
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch
@@ -0,0 +1,18 @@
+http://lists.gnu.org/archive/html/openexr-devel/2013-04/msg00031.html
+
+--- IlmImfCtl/ImfCtlApplyTransforms.h
++++ IlmImfCtl/ImfCtlApplyTransforms.h
+@@ -186,12 +186,7 @@
+ #include <vector>
+ #include <ImathBox.h>
+ #include <ImfThreading.h>
+-
+-namespace Imf
+-{
+- class Header;
+- class FrameBuffer;
+-}
++#include <ImfForward.h>
+
+ namespace Ctl
+ {
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch
new file mode 100644
index 000000000000..e35bdfc11a5c
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch
@@ -0,0 +1,12 @@
+diff -up openexr_ctl-1.0.1/OpenEXR_CTL.pc.in.pkgconfig openexr_ctl-1.0.1/OpenEXR_CTL.pc.in
+--- openexr_ctl-1.0.1/OpenEXR_CTL.pc.in.pkgconfig 2008-01-09 15:17:58.000000000 +0100
++++ openexr_ctl-1.0.1/OpenEXR_CTL.pc.in 2008-01-09 15:24:52.000000000 +0100
+@@ -7,5 +7,6 @@ OpenEXR_includedir=@includedir@/OpenEXR
+ Name: OpenEXR_CTL
+ Description: Simplified OpenEXR interface to CTL
+ Version: @OPENEXR_CTL_VERSION@
+-Libs: -L${libdir} -lIlmImfCtl @OPENEXR_LDFLAGS@ @CTL_LDFLAGS@
+-Cflags: @CTL_CXXFLAGS_PC@ @OPENEXR_CXXFLAGS@ -I${OpenEXR_includedir}
++Requires: CTL , OpenEXR
++Libs: -L${libdir} -lIlmImfCtl
++Cflags: -I${OpenEXR_includedir}