summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/opengl-apple/opengl-apple-5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/opengl-apple/opengl-apple-5.ebuild')
-rw-r--r--media-libs/opengl-apple/opengl-apple-5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/opengl-apple/opengl-apple-5.ebuild b/media-libs/opengl-apple/opengl-apple-5.ebuild
new file mode 100644
index 000000000000..b9df286d3c5b
--- /dev/null
+++ b/media-libs/opengl-apple/opengl-apple-5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit prefix
+
+DESCRIPTION="Links to Apple's OpenGL X11 implementation"
+HOMEPAGE="http://www.apple.com/"
+LICENSE="public-domain"
+KEYWORDS="-* ~ppc-macos ~x64-macos ~x86-macos"
+SLOT=0
+IUSE=""
+
+DEPEND=">=app-eselect/eselect-opengl-1.0.8-r1
+ x11-proto/glproto"
+RDEPEND="${DEPEND}"
+
+X11_OPENGL_DIR="/usr/X11R6"
+
+pkg_setup() {
+ [[ ! -d ${X11_OPENGL_DIR} ]] && \
+ die "${X11_OPENGL_DIR} not found, do you have X11/Xquartz installed?"
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/gl.pc .
+ eprefixify gl.pc
+}
+
+src_install() {
+ dodir /usr/lib/opengl/${PN}/{lib,include}
+ dodir /usr/include/GL
+
+ cd "${ED}"/usr/lib/opengl/${PN}/include || die
+ ln -s "${X11_OPENGL_DIR}"/include/GL || die
+ cd "${ED}"/usr/lib/opengl/${PN}/lib || die
+ ln -s "${X11_OPENGL_DIR}"/lib/libGL.dylib || die
+
+ cd "${ED}"/usr/include/GL || die
+ ln -s "${X11_OPENGL_DIR}"/include/GL/glu.h || die
+ ln -s "${X11_OPENGL_DIR}"/include/GL/GLwDrawA.h || die
+ ln -s "${X11_OPENGL_DIR}"/include/GL/osmesa.h || die
+ cd "${ED}"/usr/lib || die
+ ln -s "${X11_OPENGL_DIR}"/lib/libGLU.dylib || die
+ ln -s "${X11_OPENGL_DIR}"/lib/libGLw.a || die
+
+ # bug #337965
+ insinto /usr/lib/pkgconfig
+ doins "${WORKDIR}"/gl.pc
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ eselect opengl set --use-old ${PN}
+
+ elog "Note: you're using your OSX (pre-)installed OpenGL X11 implementation from ${X11_OPENGL_DIR}"
+}