summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild')
-rw-r--r--media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild b/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..be6181cfb2ab
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils multilib
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="mirror://sourceforge/${PN}.mirror/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+PATCHES=( "${FILESDIR}"/${P}-pkgconfig.patch
+ "${FILESDIR}"/${P}-pkgconfig-static.patch )
+
+RESTRICT="test" #409263
+
+src_prepare() {
+ # Stop installing LICENSE file, and install CHANGES from DOCS instead:
+ sed -i -e '/install.*FILES.*DESTINATION.*OPENJPEG_INSTALL_DOC_DIR/d' CMakeLists.txt || die
+
+ # Install doxygen docs to the right directory:
+ sed -i -e "s:DESTINATION\s*share/doc:\0/${PF}:" doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build test TESTING)
+ )
+
+ cmake-utils_src_configure
+
+ if use static-libs; then
+ mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_CODEC=OFF
+ )
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
+ fi
+}
+
+src_install() {
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
+ fi
+
+ cmake-utils_src_install
+}