summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-20 19:53:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-20 19:56:27 +0100
commitfedc905f2f73265c4108e2a4b359846d10dee66d (patch)
tree7b70eb6c98f2f9af3b2487462b27cd70bf2f86ad /media-libs/opus/opus-1.1.3-r1.ebuild
parentmedia-libs/opus: Fix overlong DESCRIPTION (diff)
downloadgentoo-fedc905f2f73265c4108e2a4b359846d10dee66d.tar.gz
gentoo-fedc905f2f73265c4108e2a4b359846d10dee66d.tar.bz2
gentoo-fedc905f2f73265c4108e2a4b359846d10dee66d.zip
media-libs/opus: Add patch for CVE-2017-0381
Gentoo-bug: 605894 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/opus/opus-1.1.3-r1.ebuild')
-rw-r--r--media-libs/opus/opus-1.1.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/opus/opus-1.1.3-r1.ebuild b/media-libs/opus/opus-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..cfe478ac2e0f
--- /dev/null
+++ b/media-libs/opus/opus-1.1.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+else
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="Open codec designed for internet transmission of interactive speech and audio"
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+INTRINSIC_FLAGS="cpu_flags_x86_sse neon"
+IUSE="ambisonics custom-modes doc static-libs ${INTRINSIC_FLAGS}"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.3-CVE-2017-0381.patch
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable ambisonics)
+ $(use_enable doc)
+ )
+ for i in ${INTRINSIC_FLAGS} ; do
+ use ${i} && myeconfargs+=( --enable-intrinsics )
+ done
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}