summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-08 04:21:57 +0300
committerStefan Strogin <steils@gentoo.org>2019-05-08 04:30:39 +0300
commit362a08b2ac66060355d1dba389637b4f3320d177 (patch)
treecb4c7a9113895b4fe53f570cbf0f684428356759 /media-libs/opus/opus-1.3.1.ebuild
parentapp-misc/yq: remove old version 2.3.4 (diff)
downloadgentoo-362a08b2ac66060355d1dba389637b4f3320d177.tar.gz
gentoo-362a08b2ac66060355d1dba389637b4f3320d177.tar.bz2
gentoo-362a08b2ac66060355d1dba389637b4f3320d177.zip
media-libs/opus: bump version to 1.3.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-libs/opus/opus-1.3.1.ebuild')
-rw-r--r--media-libs/opus/opus-1.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/opus/opus-1.3.1.ebuild b/media-libs/opus/opus-1.3.1.ebuild
new file mode 100644
index 000000000000..e2eef3fcefbc
--- /dev/null
+++ b/media-libs/opus/opus-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Open codec for interactive speech and music transmission over the Internet"
+HOMEPAGE="https://opus-codec.org/"
+SRC_URI="https://archive.mozilla.org/pub/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+INTRINSIC_FLAGS="cpu_flags_x86_sse cpu_flags_arm_neon"
+IUSE="custom-modes doc static-libs ${INTRINSIC_FLAGS}"
+
+DEPEND="doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable doc)
+ $(use_enable static-libs static)
+ )
+ for i in ${INTRINSIC_FLAGS} ; do
+ use ${i} && myeconfargs+=( --enable-intrinsics )
+ done
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}