summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-06 10:17:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-06 10:17:39 +0200
commitf700b8b81768cba873ace6b88600fce4eaab1069 (patch)
treea9022cdef7f7d23c5d969fde02ff85686c1966eb /media-libs/opusfile/opusfile-0.12.ebuild
parentmedia-libs/lilv: Bump to version 0.24.8 (diff)
downloadgentoo-f700b8b81768cba873ace6b88600fce4eaab1069.tar.gz
gentoo-f700b8b81768cba873ace6b88600fce4eaab1069.tar.bz2
gentoo-f700b8b81768cba873ace6b88600fce4eaab1069.zip
media-libs/opusfile: Bump to version 0.12
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/opusfile/opusfile-0.12.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.12.ebuild b/media-libs/opusfile/opusfile-0.12.ebuild
new file mode 100644
index 000000000000..18795c965e1c
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="https://www.opus-codec.org/"
+SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point +float +http libressl static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ $(use_enable fixed-point)\
+ $(use_enable float)
+ $(use_enable http)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}