summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-27 00:42:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-27 00:51:01 +0100
commit26db062e7b8df1334a8deb33edb799cad97cff2b (patch)
treeeb3cfc23c4254ab801b2e19ace012338a528b41d /media-libs/oyranos/oyranos-0.9.6-r1.ebuild
parentdev-python/pipfile: arm64 keyworded (bug #702190) (diff)
downloadgentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.tar.gz
gentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.tar.bz2
gentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.zip
media-libs/oyranos: Fix mesa build error, drop multilib remnant, use xdg
Closes: https://bugs.gentoo.org/671996 Closes: https://bugs.gentoo.org/672004 Closes: https://bugs.gentoo.org/672006 Closes: https://bugs.gentoo.org/680324 Closes: https://bugs.gentoo.org/689686 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/oyranos/oyranos-0.9.6-r1.ebuild')
-rw-r--r--media-libs/oyranos/oyranos-0.9.6-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-libs/oyranos/oyranos-0.9.6-r1.ebuild b/media-libs/oyranos/oyranos-0.9.6-r1.ebuild
index 05b026fa3e9d..4eee55d10f7d 100644
--- a/media-libs/oyranos/oyranos-0.9.6-r1.ebuild
+++ b/media-libs/oyranos/oyranos-0.9.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindXcm FindCUPS"
-inherit cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic xdg
DESCRIPTION="Colour management system allowing to share settings across apps and services"
HOMEPAGE="https://www.oyranos.org/"
@@ -69,7 +69,11 @@ DOCS=( {AUTHORS,ChangeLog,README}.md )
RESTRICT="test"
-PATCHES=( "${WORKDIR}/patches" )
+PATCHES=(
+ "${WORKDIR}/patches"
+ "${FILESDIR}/${P}-mesa-18.3.1.patch" # bug 671996
+ "${FILESDIR}/${P}-underlinking.patch"
+)
src_prepare() {
# remove bundled libs
@@ -77,7 +81,7 @@ src_prepare() {
cmake-utils_src_prepare
}
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-DUSE_SYSTEM_ELEKTRA=ON