summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-22 03:11:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-22 03:14:53 +1000
commitc5c785ef0305c9a3f4e92de357ba7c0a1ac56940 (patch)
treeff6e75c5511eb0d03a82f4ee681bd58318ebb2a6 /media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
parentmedia-libs/phonon-gstreamer: port to EAPI 6 (diff)
downloadgentoo-c5c785ef0305c9a3f4e92de357ba7c0a1ac56940.tar.gz
gentoo-c5c785ef0305c9a3f4e92de357ba7c0a1ac56940.tar.bz2
gentoo-c5c785ef0305c9a3f4e92de357ba7c0a1ac56940.zip
media-libs/phonon-gstreamer: reorganise variables that are set conditionally to appear in one block
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index 4be6dad00994..15057eb167b6 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -4,24 +4,23 @@
EAPI=6
-[[ ${PV} == *9999 ]] && git_eclass="git-r3"
-EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
-
MY_PN="phonon-backend-gstreamer"
MY_P=${MY_PN}-${PV}
-inherit cmake-utils multibuild ${git_eclass}
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+else
+ EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
+ inherit git-r3
+fi
+
+inherit cmake-utils multibuild
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://phonon.kde.org/"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_P}.tar.xz"
LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
-fi
SLOT="0"
IUSE="alsa debug +network +qt4 qt5"