summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/phonon-qt7/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/phonon-qt7/files')
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch28
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch29
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-noshow.patch17
3 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
new file mode 100644
index 000000000000..ae222027b892
--- /dev/null
+++ b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
@@ -0,0 +1,28 @@
+Revert commit:
+
+commit b22b86f6940d2605e78398eca4ae05c3ea44a92c
+Author: Ritt Konstantin <ritt.ks@gmail.com>
+Date: Thu Jun 10 07:38:14 2010 +0400
+
+ fix build with -fno-rtti
+
+ m_renderDrawWidget object inherits QWidget and can be safely static_cast-ed
+
+as it yields in:
+
+error: invalid static_cast from type ‘Phonon::QT7::IVideoRenderDrawWidget*’ to type ‘QWidget*’
+
+
+diff --git a/qt7/videowidget.mm b/qt7/videowidget.mm
+index 736dcdf..e471140 100644
+--- a/qt7/videowidget.mm
++++ b/qt7/videowidget.mm
+@@ -578,7 +578,7 @@ public:
+ PhononAutoReleasePool pool;
+ updateDrawFrameRect();
+ if (m_renderDrawWidget)
+- static_cast<QWidget *>(m_renderDrawWidget)->resize(size());
++ dynamic_cast<QWidget *>(m_renderDrawWidget)->resize(size());
+ break; }
+ case QEvent::Paint:{
+ PhononAutoReleasePool pool;
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
new file mode 100644
index 000000000000..6d1a5626a207
--- /dev/null
+++ b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
@@ -0,0 +1,29 @@
+disable AUGraphAddNode, it needs an AudioComponent iso Component
+need a definition for gnuOrtho2D
+
+--- phonon-qt7/qt7/audionode.mm
++++ phonon-qt7/qt7/audionode.mm
+@@ -69,9 +69,9 @@
+
+ OSStatus err = noErr;
+ #if MAC_OS_X_VERSION_MAX_ALLOWED >= MAC_OS_X_VERSION_10_5
+- if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
+- err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
+- else
++// if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
++// err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
++// else
+ #endif
+ err = AUGraphNewNode(m_audioGraph->audioGraphRef(), &description, 0, 0, &m_auNode);
+
+--- phonon-qt7/qt7/videowidget.mm
++++ phonon-qt7/qt7/videowidget.mm
+@@ -35,6 +35,8 @@
+ #import <AppKit/NSImage.h>
+ #import <QTKit/QTMovieView.h>
+
++#import <OpenGL/glu.h>
++
+ /////////////////////////////////////////////////////////////////////////////////////////
+
+ #ifdef QT_MAC_USE_COCOA // Rendering to a QTMovieView can only be done in Cocoa
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch b/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
new file mode 100644
index 000000000000..e05c2c4d9957
--- /dev/null
+++ b/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
@@ -0,0 +1,17 @@
+diff -ruN phonon-qt7.orig/CMakeLists.txt phonon-qt7/CMakeLists.txt
+--- phonon-qt7.orig/CMakeLists.txt 2011-04-24 20:22:59.000000000 +0200
++++ phonon-qt7/CMakeLists.txt 2011-04-24 20:42:15.000000000 +0200
+@@ -2,6 +2,8 @@
+
+ cmake_minimum_required(VERSION 2.6.2 FATAL_ERROR)
+
++set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
++
+ find_package(Phonon REQUIRED)
+ find_package(OpenGL REQUIRED)
+
+@@ -17,4 +19,3 @@
+ add_subdirectory(qt7)
+ endif (Q_WS_MAC)
+
+-macro_display_feature_log()