summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-06-01 01:31:26 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-01 12:53:55 +0200
commit305e38748bd6cdc35a0e8ede92c0e252b51c0927 (patch)
tree06fa403faa209b49e6ea2c458d6103fca1004827 /media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild
parentmedia-libs/pyliblo: take maintainership (diff)
downloadgentoo-305e38748bd6cdc35a0e8ede92c0e252b51c0927.tar.gz
gentoo-305e38748bd6cdc35a0e8ede92c0e252b51c0927.tar.bz2
gentoo-305e38748bd6cdc35a0e8ede92c0e252b51c0927.zip
media-libs/pyliblo: EAPI=7 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild')
-rw-r--r--media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild b/media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..3ec1fecff247
--- /dev/null
+++ b/media-libs/pyliblo/pyliblo-0.10.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the liblo OSC library"
+HOMEPAGE="http://das.nasophon.de/pyliblo"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=media-libs/liblo-0.27
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"