summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/qhull/qhull-2012.1-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/qhull/qhull-2012.1-r4.ebuild')
-rw-r--r--media-libs/qhull/qhull-2012.1-r4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/qhull/qhull-2012.1-r4.ebuild b/media-libs/qhull/qhull-2012.1-r4.ebuild
new file mode 100644
index 000000000000..56c1456b9c89
--- /dev/null
+++ b/media-libs/qhull/qhull-2012.1-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils flag-o-matic
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org/"
+SRC_URI="${HOMEPAGE}/download/${P}-src.tgz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ mycmakeargs+=(
+ -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
+ -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ # See https://bugs.gentoo.org/show_bug.cgi?id=435006
+ # If qhull-2010 is installed we need to remove its include dir so
+ # that it can be replaced with a symlink in this version.
+ rm -rf "${EROOT}"usr/include/qhull || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ # compatibility with previous installs
+ dosym libqhull /usr/include/qhull
+ if ! use doc; then
+ rm -rf "${ED}"/usr/share/doc/${PF}/html || die
+ fi
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/lib*.a || die
+ fi
+}