summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-12 18:31:19 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-12 18:31:19 +0100
commit23df3582d7aa649b85b5545bbc4bf32b9698647a (patch)
tree32c9c5cccb2d8e7d50cb1b562066983c27a4147f /media-libs/quvi/quvi-0.9.5.ebuild
parentmedia-libs/memphis: Port to EAPI 7 (diff)
downloadgentoo-23df3582d7aa649b85b5545bbc4bf32b9698647a.tar.gz
gentoo-23df3582d7aa649b85b5545bbc4bf32b9698647a.tar.bz2
gentoo-23df3582d7aa649b85b5545bbc4bf32b9698647a.zip
media-libs/quvi: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/quvi/quvi-0.9.5.ebuild')
-rw-r--r--media-libs/quvi/quvi-0.9.5.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/media-libs/quvi/quvi-0.9.5.ebuild b/media-libs/quvi/quvi-0.9.5.ebuild
index bed5ac447b8b..fbeb2f5d6dfc 100644
--- a/media-libs/quvi/quvi-0.9.5.ebuild
+++ b/media-libs/quvi/quvi-0.9.5.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
+EAPI=7
-inherit autotools-utils
+inherit autotools
DESCRIPTION="A command line tool for parsing video download links"
HOMEPAGE="http://quvi.sourceforge.net/"
@@ -15,24 +14,29 @@ SLOT="0"
KEYWORDS="amd64 ~hppa ppc64 x86"
IUSE="json nls xml"
-RDEPEND=">=dev-libs/glib-2.24:2
- >=net-misc/curl-7.21.0
- >=media-libs/libquvi-0.9.2:=
- json? ( >=dev-libs/json-glib-0.12 )
+RDEPEND="
+ dev-libs/glib:2
+ net-misc/curl:=
+ media-libs/libquvi:=
+ json? ( dev-libs/json-glib:= )
nls? ( virtual/libintl )
- xml? ( >=dev-libs/libxml2-2.7.8:2 )"
-DEPEND="${RDEPEND}
+ xml? ( dev-libs/libxml2:2= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )"
PATCHES=( "${FILESDIR}"/${PN}-0.9.1-automagic.patch )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
- --with-manual
- $(use_enable json)
+ econf \
+ --with-manual \
+ $(use_enable json) \
$(use_enable xml)
- )
- autotools-utils_src_configure
}