summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-03-07 08:24:42 +0100
committerMichael Weber <xmw@gentoo.org>2017-03-07 08:24:42 +0100
commit9cf97971322a046a0b99b0115bf16b496b6c8c2f (patch)
tree33105e4d2df9cb7a637cf565b262a1d8e4c350eb /media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild
parentmedia-libs/raspberrypi-userland-bin: Remove old version. (diff)
downloadgentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.tar.gz
gentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.tar.bz2
gentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.zip
media-libs/raspberrypi-userland-bin: Version bump.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild')
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild
new file mode 100644
index 000000000000..f011422bc21c
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}