summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 18:27:18 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 22:00:08 +0100
commit234fe7d8314b894336813b2e5edff006beab57c8 (patch)
tree8cf158ec4dfb23f43a62288afa1ddb6ec31c6173 /media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
parentmedia-libs/raspberrypi-userland-bin: set myself as maintainer (diff)
downloadgentoo-234fe7d8314b894336813b2e5edff006beab57c8.tar.gz
gentoo-234fe7d8314b894336813b2e5edff006beab57c8.tar.bz2
gentoo-234fe7d8314b894336813b2e5edff006beab57c8.zip
media-libs/raspberrypi-userland-bin: add new version 1.20190709
Cloned from existing ebuild unchanged. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild')
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
new file mode 100644
index 000000000000..de28e90041a5
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}