summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-23 04:48:09 +0000
committerSam James <sam@gentoo.org>2020-11-23 04:48:09 +0000
commit3c1d1b9e97744c059cd3cb480d019697304c7ca1 (patch)
treef81e94d781c195993bb474fdf7e787fbb5943ea2 /media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
parentmedia-libs/raspberrypi-userland: Version bump 0_pre20201022 (diff)
downloadgentoo-3c1d1b9e97744c059cd3cb480d019697304c7ca1.tar.gz
gentoo-3c1d1b9e97744c059cd3cb480d019697304c7ca1.tar.bz2
gentoo-3c1d1b9e97744c059cd3cb480d019697304c7ca1.zip
media-libs/raspberrypi-userland: QA & style fixups
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild')
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild54
1 files changed, 28 insertions, 26 deletions
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
index 9242ae883fc6..7fa3e5909284 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
@@ -9,13 +9,12 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/${PN/-//}.git"
SRC_URI=""
else
- #We base our versioning off Raspbian's
- #Go to https://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-userland/
- #Example:
- #libraspberrypi-bin-dbgsym_2+git20201022~151804+e432bc3-1_arm64.deb
- #"e432bc3" is the first 7 hex digits of the commit hash.
- #Now go to https://github.com/raspberrypi/userland/commits/master and find the
- #full hash
+ # We base our versioning on Raspbian
+ # Go to https://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-userland/
+ # Example:
+ # * libraspberrypi-bin-dbgsym_2+git20201022~151804+e432bc3-1_arm64.deb
+ # * "e432bc3" is the first 7 hex digits of the commit hash.
+ # * Go to https://github.com/raspberrypi/userland/commits/master and find the full hash
GIT_COMMIT="e432bc3400401064e2d8affa5d1454aac2cf4a00"
SRC_URI="https://github.com/raspberrypi/userland/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~arm ~arm64"
@@ -27,30 +26,22 @@ HOMEPAGE="https://github.com/raspberrypi/userland"
LICENSE="BSD"
SLOT="0"
-IUSE=""
DEPEND=""
RDEPEND="acct-group/video
!media-libs/raspberrypi-userland-bin"
-#Install in $(get_libdir)
-#See https://github.com/raspberrypi/userland/pull/650
-PATCHES=( "${FILESDIR}/${PN}-libdir.patch" )
-#Don't install includes that collide.
-PATCHES+=( "${FILESDIR}/${PN}-include.patch" )
-#See https://github.com/raspberrypi/userland/pull/655
-PATCHES+=( "${FILESDIR}/${PN}-libfdt-static.patch" )
-#See https://github.com/raspberrypi/userland/pull/659
-PATCHES+=( "${FILESDIR}/${PN}-pkgconf-arm64.patch" )
-
-pkg_setup() {
- append-ldflags $(no-as-needed)
-
- mycmakeargs=(
- -DVMCS_INSTALL_PREFIX="/usr"
- -DARM64=$(usex arm64 ON OFF)
- )
-}
+PATCHES=(
+ # Install in $(get_libdir)
+ # See https://github.com/raspberrypi/userland/pull/650
+ "${FILESDIR}/${PN}-libdir.patch"
+ # Don't install includes that collide.
+ "${FILESDIR}/${PN}-include.patch"
+ # See https://github.com/raspberrypi/userland/pull/655
+ "${FILESDIR}/${PN}-libfdt-static.patch"
+ # See https://github.com/raspberrypi/userland/pull/659
+ "${FILESDIR}/${PN}-pkgconf-arm64.patch"
+)
src_prepare() {
cmake_src_prepare
@@ -63,6 +54,17 @@ src_prepare() {
"${S}/interface/khronos/CMakeLists.txt" || die "Failed sedding interface/khronos/CMakeLists.txt"
}
+src_configure() {
+ append-ldflags $(no-as-needed)
+
+ mycmakeargs=(
+ -DVMCS_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DARM64=$(usex arm64)
+ )
+
+ cmake_src_configure
+}
+
src_install() {
cmake_src_install
udev_dorules "${FILESDIR}/92-local-vchiq-permissions.rules"