summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-27 16:47:54 -0400
committerSam James <sam@gentoo.org>2023-09-10 15:01:45 +0100
commit3cbfe9b770bd6e700b1549ef678ddf817d621ac9 (patch)
tree434bebd41ba40f8b26a212e7c4f10724d3c290c9 /media-libs/rubberband/rubberband-3.3.0.ebuild
parentdev-libs/libportal: Version bump to 0.7.1 (diff)
downloadgentoo-3cbfe9b770bd6e700b1549ef678ddf817d621ac9.tar.gz
gentoo-3cbfe9b770bd6e700b1549ef678ddf817d621ac9.tar.bz2
gentoo-3cbfe9b770bd6e700b1549ef678ddf817d621ac9.zip
media-libs/rubberband: Restrict GCC dependency to ppc
The gcc RDEPEND is presumably due to the ebuild linking against libatomic. However, this is conditioned behind either ppc or libstdc++, which the latter would imply that GCC is already installed. This needlessly pulls in GCC on musl/llvm systems, and making the gcc dependency ppc-only shouldn't cause any breakage. Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/32073 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/rubberband/rubberband-3.3.0.ebuild')
-rw-r--r--media-libs/rubberband/rubberband-3.3.0.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/media-libs/rubberband/rubberband-3.3.0.ebuild b/media-libs/rubberband/rubberband-3.3.0.ebuild
deleted file mode 100644
index f6f3a392c27f..000000000000
--- a/media-libs/rubberband/rubberband-3.3.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson-multilib flag-o-matic toolchain-funcs
-
-DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
-HOMEPAGE="https://www.breakfastquay.com/rubberband/"
-SRC_URI="https://breakfastquay.com/files/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
-IUSE="ladspa lv2 jni static-libs +programs test vamp"
-
-BDEPEND="
- virtual/pkgconfig
-"
-CDEPEND="
- media-libs/libsamplerate[${MULTILIB_USEDEP}]
- sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
- jni? ( >=virtual/jdk-1.8:* )
- ladspa? ( media-libs/ladspa-sdk[${MULTILIB_USEDEP}] )
- lv2? ( media-libs/lv2[${MULTILIB_USEDEP}] )
- programs? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
- vamp? ( media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}] )
-"
-RDEPEND="
- ${CDEPEND}
- sys-devel/gcc:*
-"
-DEPEND="${CDEPEND}"
-BDEPEND="test? ( dev-libs/boost[${MULTILIB_USEDEP}] )"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- sed -i \
- -e "s/if have_jni/if get_option('jni')/g" \
- -e "s/if have_ladspa/if get_option('ladspa')/g" \
- -e "s/if have_lv2/if get_option('lv2')/g" \
- -e "s/if have_vamp/if get_option('vamp')/g" \
- -e "s/if have_sndfile/if get_option('cmdline')/g" \
- "meson.build" || die
-
- sed -i -e "s/type: 'feature', value: 'auto'/type: 'boolean', value: 'false'/g" "meson_options.txt" || die
-
- default
-}
-
-multilib_src_configure() {
- if use ppc ; then
- # bug #827203
- # meson doesn't respect/use LIBS but mangles LDFLAGS with libs
- # correctly. Use this until we get a Meson test for libatomic.
- append-ldflags -latomic
- elif tc-is-clang && [[ $(tc-get-cxx-stdlib) == libstdc++ ]] ; then
- # bug #860078
- # undefined reference to `__atomic_is_lock_free'
- append-ldflags -latomic
- fi
-
- local emesonargs=(
- --buildtype=release
- -Dfft=fftw
- -Dresampler=libsamplerate
- -Ddefault_library=$(use static-libs && echo "both" || echo "shared")
- $(meson_use ladspa)
- $(meson_use lv2)
- $(meson_use jni)
- $(meson_use programs cmdline)
- $(meson_use vamp)
- $(meson_use test tests)
- )
- use jni && emesonargs+=(
- -Dextra_include_dirs="$(java-config -g JAVA_HOME)/include,$(java-config -g JAVA_HOME)/include/linux"
- )
- meson_src_configure
-}
-
-multilib_src_test() {
- meson_src_test --timeout-multiplier=30
-}
-
-multilib_src_install_all() {
- ! use jni && find "${ED}" -name "*.a" -delete
-}