summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-27 11:45:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-27 11:46:16 +0200
commit3062c5d68e34b8bd55a539743ebfcd6a2c8bcb1e (patch)
treee4c653592bdb6cd303075d478fafeec1d848c050 /media-libs/rubberband
parentnet-wireless/horst: Update HOMEPAGE (diff)
downloadgentoo-3062c5d68e34b8bd55a539743ebfcd6a2c8bcb1e.tar.gz
gentoo-3062c5d68e34b8bd55a539743ebfcd6a2c8bcb1e.tar.bz2
gentoo-3062c5d68e34b8bd55a539743ebfcd6a2c8bcb1e.zip
media-libs/rubberband: fixed calling ar in 1.9.0
Closes: https://bugs.gentoo.org/743883 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/files/rubberband-1.9.0-makefile.patch13
-rw-r--r--media-libs/rubberband/rubberband-1.9.0.ebuild10
2 files changed, 22 insertions, 1 deletions
diff --git a/media-libs/rubberband/files/rubberband-1.9.0-makefile.patch b/media-libs/rubberband/files/rubberband-1.9.0-makefile.patch
new file mode 100644
index 000000000000..5539162dec29
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.9.0-makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index fdddb72..86c0548 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -19,7 +19,7 @@ VAMP_PLUGIN_LIBS := @Vamp_LIBS@ $(LIBRARY_LIBS)
+ LADSPA_PLUGIN_LIBS := $(LIBRARY_LIBS)
+
+ MKDIR := mkdir
+-AR := ar
++AR ?= ar
+
+ INSTALL_BINDIR := $(PREFIX)/bin
+ INSTALL_INCDIR := $(PREFIX)/include/rubberband
diff --git a/media-libs/rubberband/rubberband-1.9.0.ebuild b/media-libs/rubberband/rubberband-1.9.0.ebuild
index 97b291d58908..38036981a9ee 100644
--- a/media-libs/rubberband/rubberband-1.9.0.ebuild
+++ b/media-libs/rubberband/rubberband-1.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
HOMEPAGE="https://www.breakfastquay.com/rubberband/"
@@ -27,6 +27,10 @@ CDEPEND="
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
src_prepare() {
default
if ! use static-libs ; then
@@ -47,6 +51,10 @@ multilib_src_configure() {
$(use_enable vamp )
}
+multilib_src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
multilib_src_install() {
# fix libdir in .pc file
sed -iE "s%/lib$%/$(get_libdir)%g" "${BUILD_DIR}/rubberband.pc.in" || die "Failed to fix .pc file"