summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-19 09:21:01 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-19 09:56:24 +0100
commit1dfc2548a4184ae6409c01b5e23928d7d9254a32 (patch)
tree241b8220469561db650b399003ead2b56f958907 /media-libs/sbc/sbc-1.4.ebuild
parentnet-wireless/bluez: Fix missing header build failure (diff)
downloadgentoo-1dfc2548a4184ae6409c01b5e23928d7d9254a32.tar.gz
gentoo-1dfc2548a4184ae6409c01b5e23928d7d9254a32.tar.bz2
gentoo-1dfc2548a4184ae6409c01b5e23928d7d9254a32.zip
media-libs/sbc: Bump to 1.4
Thanks-to: Joakim Tjernlund Closes: https://bugs.gentoo.org/675580 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/sbc/sbc-1.4.ebuild')
-rw-r--r--media-libs/sbc/sbc-1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/sbc/sbc-1.4.ebuild b/media-libs/sbc/sbc-1.4.ebuild
new file mode 100644
index 000000000000..5da8220a4970
--- /dev/null
+++ b/media-libs/sbc/sbc-1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib multilib-minimal
+
+DESCRIPTION="Audio codec to connect bluetooth HQ audio devices as headphones or loudspeakers"
+HOMEPAGE="https://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}